Bug 136156 - Calc scales a sheet with delay if enabled very large spreadsheets (macOS only?)
Summary: Calc scales a sheet with delay if enabled very large spreadsheets (macOS only?)
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Calc-large-spreadsheets
  Show dependency treegraph
 
Reported: 2020-08-26 18:04 UTC by Roman Kuznetsov
Modified: 2021-09-20 09:03 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Kuznetsov 2020-08-26 18:04:33 UTC
Description:
Calc scales a sheet with delay if enabled very large spreadsheets (macOS only?) 

Steps to Reproduce:
1. Open Calc
2. Enable Very large spreadsheets option in Tools-Options-LibreOffice Calc-Defaults
3. Restart Calc
4. Try scale a sheet using a mouse wheel => there is a some delay

PS: don't forget disable that option after testing, because it's very unstable and you always will be have crashes with it =(

Actual Results:
There is a some delay

Expected Results:
there is no any delay


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.1.0.0.alpha0+
Build ID: 6640d7f405d2970ba2825a9455926cc803284d01
CPU threads: 4; OS: Mac OS X 10.15.5; UI render: default; VCL: osx
Locale: ru-RU (ru_RU.UTF-8); UI: en-US
Calc: threaded
Comment 1 Roman Kuznetsov 2020-09-16 20:36:34 UTC
no problem in

Version: 7.1.0.0.alpha0+
Build ID: 8c18cd6823ddf4ef5ba67801a84cee26c9b5a9a6
CPU threads: 4; OS: Mac OS X 10.15.6; UI render: default; VCL: osx
Locale: ru-RU (ru_RU.UTF-8); UI: en-US
Calc: threaded

WFM