Bug 136320 - ALPHABETICAL INDEX: Concordance documentation is not precise
Summary: ALPHABETICAL INDEX: Concordance documentation is not precise
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
6.4.5.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.1.0
Keywords:
Depends on:
Blocks: Concordance-File
  Show dependency treegraph
 
Reported: 2020-08-31 09:36 UTC by BogdanB
Modified: 2020-09-18 18:28 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
video showing the bug (2.50 MB, video/mp4)
2020-08-31 09:36 UTC, BogdanB
Details
the txt file (plain text) (139 bytes, text/plain)
2020-08-31 09:37 UTC, BogdanB
Details
odf file from the video (8.94 KB, application/vnd.oasis.opendocument.text)
2020-08-31 09:37 UTC, BogdanB
Details
the project file (12.19 KB, application/vnd.oasis.opendocument.text)
2020-08-31 19:20 UTC, BogdanB
Details
the concordance file (23 bytes, text/plain)
2020-08-31 19:21 UTC, BogdanB
Details

Note You need to log in before you can comment on or make changes to this bug.
Description BogdanB 2020-08-31 09:36:23 UTC
Description:
As you can see in the video I have a simple file and a new odf file, and I want to insert a Concordance into a file.

First: open concordance doesn find any file, I have to drag & drop.
Second: after drag & drop no concordance is there...

Steps to Reproduce:
As you can see in the video I have a simple file and a new odf file, and I want to insert a Concordance into a file.

First: open concordance doesn find any file, I have to drag & drop.
Second: after drag & drop no concordance is there...

Actual Results:
No concordance. Hard to use.

Expected Results:
See the concordance


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 6.4.5.2
Build ID: a726b36747cf2001e06b58ad5db1aa3a9a1872d6
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3; 
Locale: ro-RO (ro_RO.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 BogdanB 2020-08-31 09:36:52 UTC
Created attachment 164909 [details]
video showing the bug
Comment 2 BogdanB 2020-08-31 09:37:17 UTC
Created attachment 164910 [details]
the txt file (plain text)

the txt file (plain text)
Comment 3 BogdanB 2020-08-31 09:37:37 UTC
Created attachment 164911 [details]
odf file from the video
Comment 4 Dieter 2020-08-31 15:39:11 UTC
I've tried to reproduce the bug, but LO asks for "Selection file for the alphabetical index" and format *sdi. I've never heard about that format, so I can't assess, if it is correct or not

Version: 7.0.1.2 (x64)
Build ID: 7cbcfc562f6eb6708b5ff7d7397325de9e764452
CPU threads: 4; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: threaded
Comment 5 BogdanB 2020-08-31 17:44:46 UTC
In documentation is stated that you can use a "plain text file".
So a .txt file would be enough.
Comment 6 Regina Henschel 2020-08-31 18:07:47 UTC
Your file does not have any content. So there is nothing from which the index can be created.

A concordance file must have the extension .sdi. Nevertheless it is a "plain text" file.

Your "concordance" file does not contain meaningful terms to look up in a text.

Please get help on mailing list or Ask or look into the documentation, how the tool "condordance file" works.

https://help.libreoffice.org/7.0/en-US/text/swriter/01/04120250.html
https://help.libreoffice.org/latest/en-US/text/swriter/guide/indices_index.html
Chapter 15 in the Writer Guide https://wiki.documentfoundation.org/images/a/a4/WG64-WriterGuide.pdf
Comment 7 BogdanB 2020-08-31 18:19:47 UTC
Where is a mention of the .sdi file in the documentation?... I didn't find it.
Neither in the Writer Documentation or in online help.

I never used a concordance, but when reading the Guide for Writer I should find that I need a .sdi file.
Comment 8 Regina Henschel 2020-08-31 19:01:53 UTC
From a technical point of view, a .txt file will work. But the file picker in the dialog filters on .sdi. You will need e.g. the *.* trick on Windows to see all files so that you are able to select the .txt file. So its easier to use .sdi as file name extension or rename an existing file accordingly.
Comment 9 BogdanB 2020-08-31 19:20:17 UTC
Ok, I tested. Works with .sdi. 

But I consider this deserve to be mention in the documentation. Online or Writer Guide.

On the same chapter I want to mention another problem with documentation, in Writer Guide.

Would produce an entry for macaw with
• A listing under macaw.
• An alternate listing under ara (the scientific name).
• A listing of Parrots, Macaw. <----- I CAN'T REPRODUCE THIS
• No second key (notice the two semi-colons).
• Inclusion of instances that start with a lower or upper case letter (both “macaw” and
“Macaw”).
• Inclusion of instances in which the term is a whole word or part of a longer word.

I have attach 2 files in order to test this.
Comment 10 BogdanB 2020-08-31 19:20:46 UTC
Created attachment 164935 [details]
the project file
Comment 11 BogdanB 2020-08-31 19:21:08 UTC
Created attachment 164936 [details]
the concordance file
Comment 12 BogdanB 2020-08-31 19:22:06 UTC
I can NOT reproduce this: "A listing of Parrots, Macaw." like it is said in the documentation at page 336. (Writer Guide)
Comment 13 Commit Notification 2020-09-02 10:32:00 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/be1d676ede16a062fcb2d557856df8ab8481e179

tdf#136320 more on concordance files
Comment 14 Olivier Hallot 2020-09-02 10:59:28 UTC
Fixed the documentation part.
Comment 15 BogdanB 2020-09-02 12:34:50 UTC
Oliver, I want to ask you how I can test if this was fixed?...
Comment 16 BogdanB 2020-09-10 20:08:20 UTC
Oliver, please mark this bug as resolved, and I will mark it as verified after that.

Verified.
Fixed in online documentation, but I think should be changed also in Writer Guide I mentioned in comment 12.