Download it now!
Bug 136324 - EDITING Images do not appear in the document, only placeholders
Summary: EDITING Images do not appear in the document, only placeholders
Status: RESOLVED DUPLICATE of bug 136171
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: x86-64 (AMD64) Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-08-31 10:43 UTC by thatho
Modified: 2020-09-26 21:50 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
ODT with pasted images (195.36 KB, application/vnd.oasis.opendocument.text)
2020-08-31 10:44 UTC, thatho
Details
a screenshot of the ODT open in LO7.1 (20.08 KB, image/png)
2020-08-31 10:45 UTC, thatho
Details

Note You need to log in before you can comment on or make changes to this bug.
Description thatho 2020-08-31 10:43:32 UTC
Description:
ODT is not showing image in older and new documents.
Images were pasted and and saved with LO6.4.4, LO7.1.0.0 in various documents. MS Word and LO6.4.6 opens ODTs and shows images in there.

Steps to Reproduce:
1. create new ODT
2. pasete any image (for general example https://www.libreoffice.org/assets/Uploads/donate-infographic-small-2019.png > copy image > paste (in ODT))
3.

Actual Results:
no image is displayed, only placeholders (frames) are displayed

Expected Results:
Images are shown as they are


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.1.0.0.alpha0+ (x64)
Build ID: 1e0cfd5662d95cea84e80e4fe10d52c3b1101ae6
CPU threads: 8; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win
Locale: cs-CZ (cs_CZ); UI: en-US
Calc: CL
Comment 1 thatho 2020-08-31 10:44:51 UTC
Created attachment 164914 [details]
ODT with pasted images

Images are present in the archive, when renaming ODT to ZIP

no image is shown.zip\Pictures\
Comment 2 thatho 2020-08-31 10:45:17 UTC
Created attachment 164915 [details]
a screenshot of the ODT open in LO7.1
Comment 3 Regina Henschel 2020-08-31 23:20:32 UTC
I confirm the problem. Tested with Version: 7.1.0.0.alpha0+ (x64)
Build ID: f55dc985ccba8b3f5c4dbf0c5dc8a8451a3aa626
CPU threads: 8; OS: Windows 10.0 Build 18362; UI render: Skia/Raster; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: CL

The images are contained in the file and the images are shown, if the file is opened by an older version of LibreOffice.
Comment 4 NISZ LibreOffice Team 2020-09-01 07:22:54 UTC
Images are visible in 

Version: 7.1.0.0.alpha0+ (x64)
Build ID: 1e0cfd5662d95cea84e80e4fe10d52c3b1101ae6
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: GL; VCL: win
Locale: hu-HU (hu_HU); UI: hu-HU
Calc: CL

But not in the same version with Skia enabled. 
Probably this the same as bug #136171
Comment 5 Roman Kuznetsov 2020-09-26 21:50:01 UTC
don't repro in

Version: 7.1.0.0.alpha0+ (x64)
Build ID: 06b9e703f536e2751e3cd584873e00907672cf2d
CPU threads: 4; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: Skia/Vulkan; VCL: win
Locale: ru-RU (ru_RU); UI: en-US
Calc: CL

build from 26 September, so I think it's a really duplicate of 136171

*** This bug has been marked as a duplicate of bug 136171 ***