Bug 136367 - For Each loop does not work anymore in LibreOffice 7.0
Summary: For Each loop does not work anymore in LibreOffice 7.0
Status: RESOLVED DUPLICATE of bug 135470
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
7.0.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-09-01 12:58 UTC by Roland Baudin
Modified: 2020-09-01 13:25 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roland Baudin 2020-09-01 12:58:19 UTC
The following simple basic macro does not work anymore in LibreOffice 7.0:

Sub Test

Dim a(2) as Integer

a(0) = 10
a(1) = 20
a(2) = 30

For Each n In a()
  msgbox n
Next n

End Sub

The macro should successively display the numbers 10, 20 and 30. Instead, an error message is given (at first iteration):

'Inadmissible value or data type. Data type mismatch.'

The macro works as expected in LibreOffice 6.4.5.2.

Tested in Ubuntu 20.04.1 LTS, LibreOffice 7.0.0.3 obtained from www.libreoffice.org.

100% reproducible.

Please note that this problem breaks the TexMaths extension (on Linux and Windows systems).
Comment 1 Mike Kaganski 2020-09-01 13:25:18 UTC

*** This bug has been marked as a duplicate of bug 135470 ***