Bug 136380 - Wrong Formatting Marks with font Helvetica in LibreOffice writer 7.0.0.3 (x64)
Summary: Wrong Formatting Marks with font Helvetica in LibreOffice writer 7.0.0.3 (x64)
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.0.3 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Formatting-Mark
  Show dependency treegraph
 
Reported: 2020-09-01 18:48 UTC by Martin
Modified: 2022-01-29 20:01 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
picture of the wrong control characters (53.21 KB, image/png)
2020-09-01 18:48 UTC, Martin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin 2020-09-01 18:48:39 UTC
Created attachment 164988 [details]
picture of the wrong control characters

Using LibreeOffice writer 7.0.0.3 (x64) with the font Helvetica and some others too it seems that  there is a bug with the general control character / formatting mark (see attachment). It does not occur e. g. with Arial and Times New Roman. The same bug occurs independently at 1 PC, 2 laptops and 1 Tablet, all with windows 10 64 bit. In all earlier versions of LibreOffice the format of the control character was always normal.
Comment 1 Stéphane Guillou (stragu) 2021-07-31 13:06:58 UTC
Hi Martin

I could not reproduce your issue with the following version:

Version: 7.0.6.2 (x64)
Build ID: 144abb84a525d8e30c9dbbefa69cbbf2d8d4ae3b
CPU threads: 8; OS: Windows 10.0 Build 19042; UI render: default; VCL: win
Locale: en-AU (en_AU); UI: en-US
Calc: threaded

Could you please:
- Test again with the latest bugfix version of LibreOffice 7.0 (currently 7.0.6)
- Alternatively, test with the latest master build (which can be installed alongside your existing LibreOffice version): https://dev-builds.libreoffice.org/daily/master/current.html
- If you can still see the same issue, please attach an example ODT file to this bug report so we can try to reproduce.

Thank you!

(if someone needs to install Helvetica, here it is: https://boldfonts.com/helvetica-font/ )
Comment 2 QA Administrators 2022-01-28 03:57:58 UTC Comment hidden (obsolete)
Comment 3 Martin 2022-01-29 18:29:36 UTC
I could solve the problem in the meantime. The failure was inside the used font. After having used another version of the appropriate font, everything works well.
Thank you for comments.
Martin