Bug 136405 - Merging Cells Removes Formulas
Summary: Merging Cells Removes Formulas
Status: RESOLVED DUPLICATE of bug 89951
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.2.7.1 release
Hardware: All Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-09-02 14:35 UTC by Ray
Modified: 2020-11-09 09:55 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
working (2.05 MB, video/mp4)
2020-09-02 19:09 UTC, BogdanB
Details
working another case (4.23 MB, video/mp4)
2020-09-02 19:19 UTC, BogdanB
Details
case with # (2.36 MB, video/mp4)
2020-09-02 19:22 UTC, BogdanB
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ray 2020-09-02 14:35:46 UTC
Description:
When merging a Cell into another Cell, the program copies the "answer" of the cell contents into the new cell. This needs to be reworked to copy the formula used into the new cell. When you have a complicated formula and realize you need to merge because the answer is #### and word wrap isn't working correctly (that is, when disabled on right justification, the results should overflow into the left box when it's empty, another bug I guess.) then you need the formula to be carried over that when if the input changes, then the results change. However as current, you have to remake the formula, which is not only tedious, but also counter productive. Safe Mode also allows this issue to exist 

Version: 6.2.7.1 (x64)
Build ID: 23edc44b61b830b7d749943e020e96f5a7df63bf
CPU threads: 8; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded

Actual Results:
type formula into a cell, merge that cell with another, formula is gone, but the "asnwer" is still there. 

Expected Results:
The formula should carry into the newly merged cell. 


Reproducible: Always


User Profile Reset: Yes



Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: SpreadsheetDocument
[Information guessed from browser]
OS: Windows (All)
OS is 64bit: no
Comment 1 BogdanB 2020-09-02 19:09:09 UTC
Created attachment 165046 [details]
working

Working in
Version: 6.4.5.2
Build ID: a726b36747cf2001e06b58ad5db1aa3a9a1872d6
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3; 
Locale: ro-RO (ro_RO.UTF-8); UI-Language: en-US
Calc: threaded


See the video
Comment 2 BogdanB 2020-09-02 19:19:04 UTC
Created attachment 165047 [details]
working another case

Now in this second video I merged 2 cells, both contaning formula. In this case in the first situation I lost the formula, but keep the values, because I can not have 2 formula in a cell. In the other 2 cases I keep the formula and the result.
Comment 3 BogdanB 2020-09-02 19:22:57 UTC
Created attachment 165048 [details]
case with #

When you have # you can double click on the line between cells and everything would be fine. See the video. No need for merge.
Comment 4 BogdanB 2020-09-03 19:53:46 UTC Comment hidden (obsolete)
Comment 5 Ray 2020-09-04 21:11:59 UTC
I cannot reproduce your suggested fix to double click on the line of the cell, it just clicks in the box to start typing a new value.
Comment 6 QA Administrators 2020-09-05 04:05:11 UTC Comment hidden (obsolete)
Comment 7 BogdanB 2020-09-05 19:19:55 UTC
Hi, Ray, have you watch all 3 videos? (one in comment 1, one in comment 2 and one in comment 3). If you can NOt see the video right click and download them, and watch with your mediaplayer.
Comment 8 Timur 2020-11-09 09:55:49 UTC
This looks like a duplicate of Bug 93202, which I marked as a duplicate of 89951.

*** This bug has been marked as a duplicate of bug 89951 ***