Bug 136409 - Writer crashes with large file (comment 5 is another bug)
Summary: Writer crashes with large file (comment 5 is another bug)
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.0.3 rc
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-09-02 16:04 UTC by Christian Lehmann
Modified: 2022-03-02 11:10 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
bibisect-linux-64-6.3, tail of terminal output (2.96 KB, text/plain)
2020-09-23 17:30 UTC, Terrence Enger
Details
backtrace from master (11.04 KB, text/plain)
2020-09-23 17:40 UTC, Terrence Enger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Lehmann 2020-09-02 16:04:47 UTC
Description:
Writer crashes with large file
I had earlier (January 2019) submitted the odt file I have been working on for the past years, using various versions of LO 6 and now LO 7 and with various Ubuntu 18.04 desktops, including Unity, KDE, Openbox and now Ubuntu default. In all of these configurations, I have been confronted with repeated freezes of LO. I cannot count how many of the automatic crash reports I have released over the years. The situation has not improved in the least.
There is no particular action within LO Writer that conditions the freeze. Sometimes it freezes when left alone.

Ubuntu then sometimes pops up a message saying that LO is not responding, leaving me with the choice of stopping the task or waiting. If I stop it, what follows runs as expected. If I choose ‘Wait’, then the entire Linux session freezes, and I have to restart the computer.

I have 8 GB RAM and a hard disk drive with sufficient free space for virtual memory. The odt file (an earlier version of which you have; see above) is now 1,2 MiB in its packed form and 12,6 MiB if unpacked (fodt).

As far as I can tell, there are two possible sources for the regular breakdowns:
1) The fodt file is way too large because there is insufficient formatting management. For instance, I can see many redundancies in it: A paragraph template is specified for all italics, and some word contained in it is specified for italics, in addition. This happens because strings are copied including their formatting information without respecting the target context, a bug that I reported long ago. And there are many more redundancies and inconsistencies. If LO cannot avoid the creation of these while the document is being edited, then it should have a file repair function (do I need to mention MS Office?) which corrects, purifies and condenses a file.

2) The second possible problem is memory management. If loaded into LO Writer, the Ubuntu Task Manager tells me that soffice.bin occupies 612,9 MB “Resident Set Size” and 6,3 GB “Virtual Memory Size”. Without being a specialist in memory allocation, this seems pretty much to me. If LO has the entire machine for itself, it is, nevertheless, usually stable. As soon as other applications (e.g., Thunderbird or Firefox) are running simultaneously, breakdown threatens.

Maybe on the basis of all those crash reports sent over the years (should I reveal my IP address?) and the present problem description, someone could take care of this rather serious bug.


Steps to Reproduce:
1. Load the file I sent in January 2019.
2. Load other applications.
3. Wait.

Actual Results:
First LO Writer freezes. Then Ubuntu freezes as specified in the description.

Expected Results:
Writer should be stable.


Reproducible: Always


User Profile Reset: No



Additional Info:
My most recent installation is only a week old. Resetting the profile would not make any difference.
There is, in version 7, no 'Use OpenGL' option in the preferences.
Comment 1 Telesto 2020-09-02 20:47:33 UTC
Are we talking about the file at bug 122792?
Comment 2 Christian Lehmann 2020-09-03 07:26:56 UTC
Yes.
I can submit the current version of the file if necessary. It would have to be anonymized again. If I receive instructions how to do this, I will do so.
Comment 3 Telesto 2020-09-03 12:48:06 UTC
(In reply to Christian Lehmann from comment #2)
> Yes.
> I can submit the current version of the file if necessary. It would have to
> be anonymized again. If I receive instructions how to do this, I will do so.

Find & replace CTRL+H

  Turn on Match case, and regexp:
  Find: ([bcdfghjklmnpqrstvwyz])
  Replace with: x
  Replace All
Comment 4 Christian Lehmann 2020-09-03 16:10:46 UTC
Although the following is not a crash, it is yet related to LO's trouble with large files: Writing into such a file gets increasingly tedious. Input text is displayed with enormous latency; I type much faster than the input text appears on the screen (mind you, only in LO, not in any other application). Also, characters are input with a different speed than blank spaces and text cursor movements, so these get intermixed with input text words. These are just more symptoms of the two problems that a) text files are blown up to unreasonable sizes and b) memory management is insufficient.
Comment 5 Telesto 2020-09-03 17:49:11 UTC Comment hidden (obsolete)
Comment 6 Telesto 2020-09-03 18:04:10 UTC Comment hidden (obsolete)
Comment 7 Terrence Enger 2020-09-23 17:30:36 UTC Comment hidden (obsolete)
Comment 8 Terrence Enger 2020-09-23 17:40:16 UTC Comment hidden (obsolete)
Comment 9 BogdanB 2020-09-28 06:47:53 UTC Comment hidden (obsolete)
Comment 10 Michael Stahl (allotropia) 2021-12-14 20:26:25 UTC
the scenario of comment #5 and all the subsequent comments relating to it was separately filed as bug 139843

the freeze in the description sounds different, as if there's no specific steps known to cause the freeze.

so i'll clean up the issue status here to make it less confusing and set this back to UNCONFIRMED.
Comment 11 Michael Stahl (allotropia) 2021-12-14 20:32:30 UTC
everything copied to bug 139843

i can't mark the 2 attachments as obsolete.
Comment 12 Terrence Enger 2021-12-19 18:50:13 UTC
(In reply to Michael Stahl (allotropia) from comment #11)
> everything copied to bug 139843
> 
> i can't mark the 2 attachments as obsolete.

I have marked the two attachments obsolete.  The links to them in bug
139843 comment 9 still work.
Comment 13 John Watts 2022-03-01 09:33:00 UTC
I can no longer open a file with over 3000 pages. I am using Windows 10 and Writer just crashes if I try to open the file.
Comment 14 Christian Lehmann 2022-03-01 10:00:24 UTC
LO 7.2.4.1 on Windows 10:
The file I submitted several times before (now 700 pages, 1.788 KB on disk) caused repeated crashes of LO Writer in the past weeks. Every time, I sent an automatic crash report. Apart from the sheer size of the file, which obviously plays a role, the etiology is not easy to pin down, as there seems to be no specific editor operation which triggers it. It appears that this happens (only?) if the same document is open in a second window.
If anybody has helpful suggestions how to nail down the cause, I (and others) will be grateful.
Comment 15 Timur 2022-03-02 10:54:28 UTC
I guess this all is about attachment 148801 [details] (just write like that, not "the file from the other bug..)
There were different problems but I don't see some testing with LO master 7.4+.
I close as WFM.
If this file causes crash or hang, please write exact steps to reproduce. 
If similar but newer/larger file hangs, please attach anonymized, write exact repro steps and set Unconfirmed.
Comment 16 Timur 2022-03-02 10:57:03 UTC
Note that if you get crash, and send automatic crash report, you should write the link here.
But link itself will not help without repro steps. 
As seen in bug report form, "User Profile Reset: " indicates that 1st step should be profile reset or delete (or temp. rename if you customized it, to test).
Comment 17 Christian Lehmann 2022-03-02 11:10:26 UTC
(In reply to Timur from comment #15)
> I guess this all is about attachment 148801 [details] (just write like that,
> not "the file from the other bug..)
> There were different problems but I don't see some testing with LO master
> 7.4+.
> I close as WFM.
> If this file causes crash or hang, please write exact steps to reproduce. 
> If similar but newer/larger file hangs, please attach anonymized, write
> exact repro steps and set Unconfirmed.

Just one remark: It appears that there are crashes which are not reproducible, so "exact steps" cannot be described. I had hoped that the automatic crash reports are good for something. But maybe the only thing that developers can learn from them is that a certain version of LO sometimes crashes ...