Bug 136421 - switch LibO layout and back delete user specific settings
Summary: switch LibO layout and back delete user specific settings
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: User-Profile
  Show dependency treegraph
 
Reported: 2020-09-03 05:52 UTC by andreas_k
Modified: 2020-09-27 14:30 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description andreas_k 2020-09-03 05:52:04 UTC
the user can show/hide statusbar, sidebar, different toolbars and all this changes will be saved at the user profile.

But if you switch the Layout (View -> User Interface -> ) from Standard to Sidebar and back the settings from Standard interface will be deleted. Or at least the Standard interface use the default settings and not the user specific settings.

So witch layout will delete user specific settings.
Comment 1 Heiko Tietze 2020-09-22 09:17:17 UTC
Not tested but this would be a serious show-stopper. Xisco, please decide if importance should be raised.
Comment 2 andreas_k 2020-09-26 08:15:49 UTC
Maxim could you have a look at this bug, cause it would be a really showstopper when the layout selector dialog will run.
Comment 3 Maxim Monastirsky 2020-09-26 22:42:26 UTC
Can't reproduce. For the test I made the Logo and Find toolbars visible, and moved them to a different docking location. Then I switched to Sidebar mode and back to Standard. All toolbars were still where I left them.

Please give exact steps to reproduce the problem.
Comment 4 andreas_k 2020-09-27 11:00:59 UTC
1. clean user dir
2. standard toolbar layout
3. menubar -> view -> toolbar -> hide formating
restart
4. menubar -> view -> layout -> sidebar
restart
5. menubar -> view -> layout -> standard toolbar
=> formating toolbar isn't hide any more.
Comment 5 Maxim Monastirsky 2020-09-27 11:26:19 UTC
(In reply to andreas_k from comment #4)
> 1. clean user dir
> 2. standard toolbar layout
> 3. menubar -> view -> toolbar -> hide formating
> restart
> 4. menubar -> view -> layout -> sidebar
> restart
> 5. menubar -> view -> layout -> standard toolbar
> => formating toolbar isn't hide any more.

I'm afraid this was by design. The formatting toolbar is listed as mandatory here: https://opengrok.libreoffice.org/xref/core/officecfg/registry/data/org/openoffice/Office/UI/ToolbarMode.xcu?r=c1b084de#38
Comment 6 Heiko Tietze 2020-09-27 14:30:58 UTC
If this issue is formatting toolbar only we can resolve as NAB.