Download it now!
Bug 136424 - Custom formatting in table resets when rows added or deleted
Summary: Custom formatting in table resets when rows added or deleted
Status: RESOLVED DUPLICATE of bug 126008
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.0.3 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Tables-Style
  Show dependency treegraph
 
Reported: 2020-09-03 06:45 UTC by Tim Chambers
Modified: 2020-09-03 15:20 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file (9.75 KB, application/vnd.oasis.opendocument.text)
2020-09-03 14:06 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tim Chambers 2020-09-03 06:45:19 UTC
If I create a table in a writer document, and assign that table a table style, then customise the formatting of some entries (say, highlighting an entry with bold in one table cell), that custom formatting is lost when rows are added to or deleted from the table.

This is unexpected behaviour and on a larger table can result in the loss of significant amounts of custom formatting. FOr some documents and workflows it is not feasible to keep all tables in a plain format and do the formatting at the end as iterative changes can be required.

The expected behaviour would not be to reapply formatting to the table, just to the newly added rows.
Comment 1 Telesto 2020-09-03 14:06:54 UTC
Created attachment 165095 [details]
Example file
Comment 2 Telesto 2020-09-03 14:07:35 UTC
Confirm.. press tab at the last cell in the table and formatting disappears
Version: 7.1.0.0.alpha0+ (x64)
Build ID: 1e0cfd5662d95cea84e80e4fe10d52c3b1101ae6
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 3 Telesto 2020-09-03 14:08:48 UTC
Also in 
6.0
Comment 4 Telesto 2020-09-03 14:10:19 UTC
@Jim
Another table formatting one, in case you can't get enough of it
Comment 5 Maxim Monastirsky 2020-09-03 15:20:19 UTC

*** This bug has been marked as a duplicate of bug 126008 ***