Download it now!
Bug 136428 - cannot shrink width of Styles panel
Summary: cannot shrink width of Styles panel
Status: RESOLVED DUPLICATE of bug 131947
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.0.3 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Sidebar-UI-UX
  Show dependency treegraph
 
Reported: 2020-09-03 10:12 UTC by Christian Lehmann
Modified: 2020-10-01 10:21 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Screen recording demonstrating limits of side panel width (1.03 MB, video/mp4)
2020-09-03 14:45 UTC, Christian Lehmann
Details
Video showing adjustment of width of navigator bar (3.87 MB, video/mp4)
2020-09-09 06:47 UTC, Christian Lehmann
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Lehmann 2020-09-03 10:12:04 UTC
Description:
When displaying the Styles panel (ctrl-f5), it has a width that far exceeds the length of the names of the styles enumerated. Apparently, it is the width needed to display, on top of the panel, both the six icons of the different style types and two additional icons. Using the cursor, I can increase the width of the panel, but cannot shrink it. As a result, this panel occupies space that I need to display the document.

Steps to Reproduce:
1. Open Writer.
2. Hit ctrl-f5.
3. Use the cursor to move the border between document and styles panel to the right.

Actual Results:
None; cannot shift the border.

Expected Results:
Should be possible to shift the border up to some reasonable limit.


Reproducible: Always


User Profile Reset: No



Additional Info:
This bug is new in LO version 7.
Suggestion: Decrease the minimum width to some useful value, e.g. to display only the six style-type icons.
Comment 1 Dieter 2020-09-03 11:36:46 UTC
I can't confirm it with

Version: 7.0.1.2 (x64)
Build ID: 7cbcfc562f6eb6708b5ff7d7397325de9e764452
CPU threads: 4; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: threaded

I'm not sure, but I remember a similar bug, that has been fixed recently. But I couldn't find it. Perhaps you can try with LO 7.0.1.2.
Comment 2 Christian Lehmann 2020-09-03 14:45:40 UTC
Created attachment 165098 [details]
Screen recording demonstrating limits of side panel width

I can't confirm your inability to confirm. After installing version 7.0.1.2, things have become worse. There is now not only the oversized minimum width (as before), but also a (probably reasonable) maximum width. See screen recording attached.
Comment 3 Dieter 2020-09-05 05:04:13 UTC
(In reply to Christian Lehmann from comment #2)
> Created attachment 165098 [details]
> Screen recording demonstrating limits of side panel width
> 
> I can't confirm your inability to confirm. After installing version 7.0.1.2,
> things have become worse. There is now not only the oversized minimum width
> (as before), but also a (probably reasonable) maximum width. See screen
> recording attached.

Thanks for the screencast. It shows the expected result. You can't reduce width because of the icons in top line.

=> NOTABUG

Feel free to change it back to UNCONFIRMED with a short reasoning, if you disagree.
Comment 4 Christian Lehmann 2020-09-05 07:02:48 UTC
As long as it is not obvious how to get rid of those icons (which I did not choose to display), this remains a bug for me.
Comment 5 Dieter 2020-09-05 13:34:06 UTC
(In reply to Christian Lehmann from comment #4)
> As long as it is not obvious how to get rid of those icons (which I did not
> choose to display), this remains a bug for me.

Icons (for changing to the different type of styles)are part of the standard UI. I don't think it is possible to delete them.
Comment 6 Christian Lehmann 2020-09-08 14:59:56 UTC
But then it _is_ a bug! Consider the Navigator side bar: The user is allowed to shrink its width despite the fact that the top icons will then be hidden. Thus, it is not the case that the top icons prevent shrinking the width of a side bar. Nor should they do so.

It is quite a different question what should happen to the icons if the user shrinks the width so that they do not fit any longer. I would prefer that they do not get hidden and instead line wrap applies to them. However, I may leave this humbly up to the developers.
Comment 7 Dieter 2020-09-08 17:17:39 UTC
(In reply to Christian Lehmann from comment #6)
> But then it _is_ a bug! Consider the Navigator side bar: The user is allowed
> to shrink its width despite the fact that the top icons will then be hidden.

I can only shrink navigator in floating window, but not in the sidebar.
Comment 8 Christian Lehmann 2020-09-09 06:46:22 UTC
On Ubuntu 18.04, the sidebar is shrinkable. Here is a video showing it. To my mind, this is as it should be. Also remember that the same was possible with the style bar up to version 6. The impossibility is an "innovation" of version 7.
Comment 9 Christian Lehmann 2020-09-09 06:47:55 UTC
Created attachment 165303 [details]
Video showing adjustment of width of navigator bar

There are apparently no limits to enhancing and shrinking the width of the navigator window in the side bar.
Comment 10 Dieter 2020-09-09 08:07:43 UTC
Thank you for the video. So there seems to be an additional problem with LO for Windows. I can't shrink it for any of the sidebar decks.

So I change status to NEW, but I add also Design-Team to make it sure, that the current situation is not the desired one.
Comment 11 Apt 2020-09-14 17:26:14 UTC
My experience is much the same as Dieter's: excessive minimum width of sidebar. Can only reduce the width of the sidebar past a certain minimum when the sidebar when it's a floating window and not when it's docked. Using Windows 10. LO version 7.1
Comment 12 Timur 2020-09-15 15:09:13 UTC
Looks like duplicate, explain if not and why it wasn't marked.

*** This bug has been marked as a duplicate of bug 131947 ***
Comment 13 Heiko Tietze 2020-10-01 10:21:58 UTC
Besides the duplicate issue, which is likely a bug, the sidebar width should initially be defined by the largest deck. Decks with less content should be resizable up to the width of its controls.