Download it now!
Bug 136430 - Crash when tying to move chart data label
Summary: Crash when tying to move chart data label
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
7.0.0.3 release
Hardware: All All
: medium normal
Assignee: Balázs Varga
URL:
Whiteboard: target:7.1.0 target:7.0.3
Keywords:
: 136020 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-09-03 12:28 UTC by NISZ LibreOffice Team
Modified: 2020-10-06 10:53 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file from Calc (17.74 KB, application/vnd.oasis.opendocument.spreadsheet)
2020-09-03 12:28 UTC, NISZ LibreOffice Team
Details
Screenshot of the crash in Calc (40.03 KB, image/png)
2020-09-03 12:28 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2020-09-03 12:28:22 UTC
Created attachment 165084 [details]
Example file from Calc

When a charts data label is moved with the cursor keys and not the mouse, Calc crashes.

Steps to reproduce:
    1. Open attached file
    2. Select one data label
    3. Try to move it with the arrow keys

Actual results:
Fatal Error: -1

Expected results:
Label is moved, but at least no crash.

LibreOffice details:
Version: 7.0.0.3 (x64)
Build ID: 8061b3e9204bef6b321a21033174034a5e2ea88e
CPU szálak: 4; OS: Windows 6.3 Build 9600; Felületmegjelenítés: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: hu-HU
Calc: CL

In 6.4 chart data labels could not have been moved so arrow keys did nothing.
Comment 1 NISZ LibreOffice Team 2020-09-03 12:28:36 UTC
Created attachment 165085 [details]
Screenshot of the crash in Calc
Comment 2 Regina Henschel 2020-09-03 13:27:36 UTC
Likely same as bug 136020.
Comment 3 Xisco Faulí 2020-09-07 08:49:16 UTC
*** Bug 136020 has been marked as a duplicate of this bug. ***
Comment 4 Commit Notification 2020-09-07 10:45:28 UTC
Balazs Varga committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/c10d5854b5427ad1bfffc00e77a9306c99c78c63

tdf#136430 Fix chart crash trying to move data labels

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Xisco Faulí 2020-09-29 15:25:12 UTC
Verified in

Version: 7.1.0.0.alpha0+
Build ID: cd85546a2fbdade42f80fd3b6bd650791db9f32d
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Balázs Varga, thanks for fixing this issue!!
Comment 6 Commit Notification 2020-09-29 17:15:22 UTC
Balazs Varga committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/8c7bb2d43fefe66f0fed3971a84bcd1ee80ee0c2

tdf#136430 Fix chart crash trying to move data labels

It will be available in 7.0.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2020-10-02 07:48:09 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/647958099600923d9ba3a57101891f62de326f4b

tdf#136430, tdf#136573: sc: Add UItest

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2020-10-03 19:48:39 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/5872f0c0d206466ad78e92be3d7d551b7ff4dbf1

Revert "tdf#136430, tdf#136573: sc: Add UItest"

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2020-10-06 10:53:54 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/d34e969c888219bd3739fc4a8ef330c77f7e7adf

tdf#136430, tdf#136573: sc: Add UItest (take 2)

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.