Bug 136464 - EDITING: Find Bar behavior is inconsistent and partly cumbersome
Summary: EDITING: Find Bar behavior is inconsistent and partly cumbersome
Status: RESOLVED DUPLICATE of bug 136269
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.0.3 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Find-Toolbar
  Show dependency treegraph
 
Reported: 2020-09-04 10:01 UTC by Christian Lehmann
Modified: 2020-09-09 14:19 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Lehmann 2020-09-04 10:01:21 UTC
Description:
When activating "Find", i.e. opening the Find Bar, the previous search item is displayed for reuse. This has been so in earlier versions and is okay.
However, as of LO version 7, it is no longer highlighted. Thus, if I input a different search item, it is inserted in front of the one offered for reuse. This is a new bug.

Incidentally, if the Find Bar is not closed after leaving it, the behavior is as follows:
If the graphic cursor was in the document editing window and is then placed back in the Find Bar by clicking in it, the search text displayed is highlighted. (Correct)
If the graphic cursor was in a different (non-LO) window and is placed back into the LO window by clicking anywhere in it, the search text in the Find bar is highlighted. (Unnecessary)

Steps to Reproduce:
1. CTRL-f
2. In the Find Bar, search for "XX".
3. Close the Find Bar.
4. CTRL-f

Actual Results:
In the Find Bar, XX is offered for reuse. However, it is not highlighted.

Expected Results:
It should be highlighted.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.0.1.2
Build ID: 7cbcfc562f6eb6708b5ff7d7397325de9e764452
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: de-DE (de_DE.UTF-8); UI: en-US
Calc: threaded
Comment 1 BogdanB 2020-09-04 14:39:03 UTC
Confirmed with
Version: 7.0.1.2
Build ID: 7cbcfc562f6eb6708b5ff7d7397325de9e764452
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-US (ro_RO.UTF-8); UI: en-US
Calc: threaded

Christian, this bug is in the attention of developers, will be solved in the next release. Thanks for reporting. A similar bug was filled for Calc:
https://bugs.documentfoundation.org/show_bug.cgi?id=136269 

And this one was already solved in 3 days from reporting. 
And available in a release version in 20th of September.
Comment 2 Caolán McNamara 2020-09-07 12:03:01 UTC

*** This bug has been marked as a duplicate of bug 136269 ***
Comment 3 Christian Lehmann 2020-09-09 14:12:40 UTC
Fine. However, the present report contains a piece of additional information that may be useful to heed in Writer. See original description, "Incidentally ...".
Comment 4 BogdanB 2020-09-09 14:19:34 UTC
You can NOT report 2 bugs in a bug report, so I consider the case with the Find shoing the previous search unselected. For another problem it is needed another bug report.