Bug 136488 - LO 7 apps do not start on Windows 2012 R2 Terminal Server multiuser environment
Summary: LO 7 apps do not start on Windows 2012 R2 Terminal Server multiuser environment
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
7.0.0.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Remote
  Show dependency treegraph
 
Reported: 2020-09-05 07:01 UTC by Alka o.p.s.
Modified: 2022-05-18 12:56 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Error message shown to users trying to strat LO apps (202.85 KB, image/jpeg)
2020-09-05 07:02 UTC, Alka o.p.s.
Details
Newly created users can't even start the app (2.70 MB, application/octet-stream)
2020-09-05 07:09 UTC, Alka o.p.s.
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alka o.p.s. 2020-09-05 07:01:02 UTC
Description:
Libre Office apps (Witter, Calc, Impres...) can not start in freshly installed Windows 2012 R2 environment in Terminal server mode when more than one user is trying to use the LO apps. 
The second and further user when trying to start the app either gets a error message or the LO splash screen is just appearing and disappearing in infinite loop. It is not possible to terminate the app through task manager, only log off helps.
The error message in CZ reads:

----------------
K vašim osobním nastavením právě přistupuje jiná instance LibreOffice, nebo jsou tato nastavení zamknuta.
Simultánní přístup může způsobit, že osobní nastavení nebudou konzistentní. Než budete pokračovat, ujistěte se, že uživatel '' uzavřel LibreOffice na počítači ''.

Opravdu si přejete pokračovat?
----------------

I believe the translation can be like:

Another instance of LibreOffice is accessing your personal settings, or the settings are locked.
Simultaneous access can cause personal settings to be inconsistent. Before proceeding, make sure that the user '' has closed LibreOffice on the computer ''.

Do you really want to continue?



Steps to Reproduce:
1. Installed fresh W2K12 R2, enabled terminal services
2. Installed LibreOffice 7.0.0.3 in the TS mode, server rebooted
3. first RDP user logs in and the applications starts OK (writer, calc, any...)
4. first user stays logged in and second RDP user logs in and tries to strat any LO app - either error message is displayed or the splash screen is showing indefinitely
5. Updated to latest available version, still the same result.
6. Tested also on unused first time login remote users = fresh user profiles, same result

Actual Results:
The application for the second ant other users can not be started. When the infinite loop of splash screens is shown, the user must log off, there is no way to stop it but log off

Expected Results:
The application should start for every remote user logged in



Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.0.1.2 (x64)
Build ID: 7cbcfc562f6eb6708b5ff7d7397325de9e764452
CPU threads: 16; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: cs-CZ (cs_CZ); UI: cs-CZ
Calc: threaded
Comment 1 Alka o.p.s. 2020-09-05 07:02:06 UTC
Created attachment 165171 [details]
Error message shown to users trying to strat LO apps
Comment 2 Alka o.p.s. 2020-09-05 07:09:14 UTC
Created attachment 165172 [details]
Newly created users can't even start the app
Comment 3 Timur 2020-09-22 13:37:15 UTC
I tested this on Win2012R2 server with RDS.
I could run normally installed LO 7.1+ for 2 different users without an issue. 
RDS is the new name for Terminal Services (which you mention in Steps) but this bug is likely about Terminal Server (used with licenses).
Comment 4 Timur 2020-09-22 13:37:26 UTC
To add TS to Standard or Datacenter edition of Windows Server, if someone can do it: 
1. Server Manager -- Add roles and features -- Role-based -- Server Roles -- Remote Desktop Services -- select RD Session Host and RD Licensing Role Services -- finish wizard.
2. Open gpedit.msc.  Set the licensing mode to match the type of purchased RDS CALs you have, and Specify the FQDN of your RD Licensing server (localhost is fine in your case)
Computer Configuration\ Administrative Templates\ Windows Components\ Remote Desktop Services\ Remote Desktop Session Host\ Licensing\
Use the specified Remote Desktop licensing servers     Enabled
Set the Remote Desktop licensing mode     Enabled
3. Open RD Licensing Manager (licmgr.exe).  Activate the server, then Install your purchased RDS CALs

To install in TS mode: "Change User /Install". 

Note: Before reporting the bug, it's always advisable to test with LO master which is now 7.1+, from https://dev-builds.libreoffice.org/daily/master/current.html.
But for this issue, I doubt version is important.
Comment 5 Alka o.p.s. 2020-09-23 05:34:42 UTC
Yes, I do confirm, I am running 2012 R2 server in TS mode for remote access for dozens of users.
They use any other application without a problem (Office 2016, Firefox, Chrome, Adober Reader X, Java apps, IrfanView, FreeCommander).

All apps are installed in TS mode (by running the install from the Control panel option "install apps for terminal server")

I used and reported the latest version available at the moment when it was reported.

My conclusion is that the App is somehow trying to write to a location which is not available for standard users in Terminal server, I woudl expect all changes to used files must be done solely in the user profile folder. But I did not have a chance to check which files are being accessed for writing, perhaps some filemon by sys internals can tell more, but as it is a production environment, I am a bit afraid to play with it and also I am not sure what everything LO is reading/writing to in a standard setup.

If you ask me a specific thing to do I will certainly be happy to test and give you feedback.
 
(In reply to Timur from comment #3)
> I tested this on Win2012R2 server with RDS.
> I could run normally installed LO 7.1+ for 2 different users without an
> issue. 
> RDS is the new name for Terminal Services (which you mention in Steps) but
> this bug is likely about Terminal Server (used with licenses).
Comment 6 Xisco Faulí 2021-03-31 14:46:17 UTC
Thank you for reporting the bug.
Could you please try to reproduce it with the latest version of LibreOffice from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the latest version.
Comment 7 Alka o.p.s. 2021-04-01 11:03:57 UTC
Unfortunately the target server is no longer available, it was replaced by a whole new setup and there is no more LO installed any more. So I cant reproduce on the same setup I had when I was registering the bug. I am sorry.
My conclusion was that the RDP setup is not supported with LO where some shared files when accessed by more than 1 user caused issue. However I cant prove this any more.
Comment 8 Timur 2022-05-18 12:56:27 UTC
So nobody has a setup to test this. 
Let's assume this can work, according to his page which confirmes using LO with TS.
https://www.urz.uni-heidelberg.de/en/node/18/desktop-and-workstations/windows-terminal-server
https://www.en.it.physik.uni-muenchen.de/dienste/betriebssysteme/windows/software/index.html