Bug 136569 - UI: Style inspector; short list for; most common formatting
Summary: UI: Style inspector; short list for; most common formatting
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Styles_Inspector
  Show dependency treegraph
 
Reported: 2020-09-08 11:42 UTC by Telesto
Modified: 2020-10-16 12:23 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file (23.67 KB, application/vnd.oasis.opendocument.text)
2020-09-08 11:42 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-09-08 11:42:18 UTC
Description:
UI: Style inspector; short list for; most common formatting (hiding the rest?)

Steps to Reproduce:
1. Open the attached file
2. Click footnote
3. Sidebar -> Style inspector.. Style Footnote is expanded (OK). However Paragraph style hidden (not totally surprisingly). 

However if you want to no say the font.. you have to expand Paragraph Style. And look through the long list of all style settings..

If you screen a document you might want to look at 'some' settings.. all the time, instead of the full list?

 

Actual Results:
Some info hidden away you might want to see.. always the need to expand

Expected Results:
Maybe some short list


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.1.0.0.alpha0+ (x64)
Build ID: e8b8e7be0b2ad693224cd94062a55610eb69df7e
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 1 Telesto 2020-09-08 11:42:31 UTC
Created attachment 165268 [details]
Example file
Comment 2 Telesto 2020-09-08 11:47:42 UTC
@Mike
One of those incomplete ideas of mine .. in this case I searched for the font used in they footnote.. I had to expand Paragraph style & go through the whole list. Looked over it.. etc
Comment 3 Thomas Lendo 2020-10-14 21:06:20 UTC
Telesto: I don't understand the bug summary: "UI: Style inspector; short list for; most common formatting". What does that mean?

To comment 0: The Default Paragraph Style always is collapsed. I assume it's because a) the list is so long that it would upset the users to scroll every time so much and b) the Default Paragraph Style shouldn't be the subject of any change.

It was in one of the endless style bugs here long time ago ;-) but there I learned that the Default style shouldn't be changed by the user as it's the basis for all other styles as well (not only text paragraphs but also Footnotes, Headings etc. and changing Default could have negative side effects). This is the reason that Text body should be the base paragraph style that users are using and Default paragraph style is only the internal basis and shouldn't be used within the document.
Comment 4 Heiko Tietze 2020-10-16 11:03:05 UTC
As Thomas pointed out you should use another PS (discussion whether or not to allow modifying Default somewhere else please). The SI is a tool to inspect the hierarchy assuming you have Default > Heading, Default > Text, Default > Citation, etc. If you change Default to let's say using a proportional font affects all children styles- and you will get it from the visual inspection. Adding a filter to the SI contradicts its goal to show all _modifications_. Clearly a NAB/WF.
Comment 5 Telesto 2020-10-16 12:23:22 UTC
(In reply to Heiko Tietze from comment #4)
> As Thomas pointed out you should use another PS (discussion whether or not
> to allow modifying Default somewhere else please). The SI is a tool to
> inspect the hierarchy assuming you have Default > Heading, Default > Text,
> Default > Citation, etc. If you change Default to let's say using a
> proportional font affects all children styles- and you will get it from the
> visual inspection. Adding a filter to the SI contradicts its goal to show
> all _modifications_. Clearly a NAB/WF.

Essence.. Expanding a PS results in a very very long list.. with all attributes. You have to search for certain entry's. Instead of showing all, sometimes only interested about here a style diverges from default. Instead of having to skip/scroll through everything I don't care about.

Where "I" can be read as user. Personally not really care.. except the instance I looked at I searched for the deviations.. And that needed more effort compared to anticipated. 

So bug doc as such might be misleading (looks like I'm 'inventing this right here and now)... 

In this case it was probably more about the inherited stuff. So Footnote Style doesn't stand on its own. But inheriting Default Page Style stuff (in this case). So PS doesn't make clear they hierarchy. And collapsing of PS is obvious (else a long list), but on they other hand still hiding relevant info if you ask me.

We will know soon enough.. after the release.. Except we still miss the numbers on how many people actually will use they Style Inspector (or if it doesn't solve the problems people encounter). But that's over outside the scope here.