Download it now!
Bug 136611 - Crash: Change Corner Style on sidebar with selecting Data Series.
Summary: Crash: Change Corner Style on sidebar with selecting Data Series.
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL: https://crashreport.libreoffice.org/s...
Whiteboard: target:7.1.0 target:7.0.4
Keywords: haveBacktrace
: 137435 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-09-09 12:54 UTC by sawakaze
Modified: 2020-12-29 05:50 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
ScreenCast (1.20 MB, video/x-matroska)
2020-09-09 12:55 UTC, sawakaze
Details
bt with debug symbols (7.33 KB, text/plain)
2020-09-09 19:29 UTC, Julien Nabet
Details
Very simple reproducer document (15.64 KB, application/vnd.oasis.opendocument.spreadsheet)
2020-11-03 11:23 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sawakaze 2020-09-09 12:54:34 UTC
Description:
After following steps, Application was crashed.

if my description is uncleared, please see screencast(attachment)

Steps to Reproduce:
1. open calc
2. input data
3. create graph
4. select Data Series 
5. Open Sidebar -> Line
6. change Corner style
--> crash

Actual Results:
application crash

On console following message shown

terminate called after throwing an instance of 'com::sun::star::beans::UnknownPropertyException'


Expected Results:
not crash


Reproducible: Always


User Profile Reset: No



Additional Info:
I confirmed this version.

Version: 7.1.0.0.alpha0+
Build ID: eacb86d332563a5651793f1aaa687528736a7bfb
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3
Locale: ja-JP (ja_JP.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-09-07_09:02:58
Calc: threaded
Comment 1 sawakaze 2020-09-09 12:55:32 UTC
Created attachment 165319 [details]
ScreenCast

if my description is uncleared, please see attachment
Comment 2 Julien Nabet 2020-09-09 19:29:55 UTC
Created attachment 165336 [details]
bt with debug symbols

On pc Debian x86-64 with master sources updated today, I could reproduce this.
Comment 3 Julien Nabet 2020-09-09 20:22:32 UTC
Xisco/Heiko: Chart part, at least side bar for properties of chart, seems quite broken in general.
Choose transparency in sidebar, no effect.
Double click one of the data series to format the line and put the transparency => effect ok.
Moreover values aren't synchronized between 2 parts.
I know I'm describing another bug but it shows there's really something wrong here.

I'm afraid that after Firebird, then Base in general, Chart module is the next forgotten part.
(sorry for digressing).
Comment 4 Xisco Faulí 2020-09-10 09:06:05 UTC
This looks like a duplicate of bug 133630

*** This bug has been marked as a duplicate of bug 133630 ***
Comment 5 NISZ LibreOffice Team 2020-11-03 11:23:45 UTC
Created attachment 166968 [details]
Very simple reproducer document

To reproduce this:
- Enable sidebar
- Edit the chart, select the line
- At the bottom of the sidebar there is the Line panel, set a different Corner Style -> crash

Version: 7.1.0.0.alpha1+ (x64)
Build ID: bd8edf5d2ac579e51bfbf5fa6061909a67a309c7
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: en-US
Calc: CL

From 
Version: 7.0.0.3 (x64)
Build ID: 8061b3e9204bef6b321a21033174034a5e2ea88e
CPU szálak: 4; OS: Windows 6.3 Build 9600; Felületmegjelenítés: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: hu-HU
Calc: CL

I also get this crash and this report:
https://crashreport.libreoffice.org/stats/crash_details/8150d2d3-f230-4afa-ac13-4111435e0bff
Comment 6 NISZ LibreOffice Team 2020-11-03 11:25:52 UTC
Back to NEW.
This should not be a duplicate of bug #133630 since that is about assert errors popping up left and right. This crash is not an assert.
Comment 7 NISZ LibreOffice Team 2020-11-03 12:33:46 UTC
This seems to have started with:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=4f6d95ead1286748810e937c7672de08b8b39a38

author	Caolán McNamara <caolanm@redhat.com>	2020-01-06 09:51:42 +0000
committer	Caolán McNamara <caolanm@redhat.com>	2020-01-08 09:50:52 +0100

weld LinePropertyPanel

Before this commit the Corner style and Cap style dropdowns were not even visible for line chart lines. 
Since the bug #95038 requesting arrow support for chart lines is still open, that made sense.

Adding CC to: Caolán McNamara
Comment 8 Heiko Tietze 2020-11-03 13:59:52 UTC
(In reply to Julien Nabet from comment #3)
> Xisco/Heiko: Chart part, at least side bar for properties of chart, seems
> quite broken in general.

It's also a mess for UX. All attributes dumped into the sidebar.
Comment 9 Commit Notification 2020-11-03 16:16:40 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/2359ad3305c20b0654bdb2ff41a4703c833f7734

Resolves: tdf#136611 chart doesn't support corner style or caps

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2020-11-08 20:15:51 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/dbeb3f64a99e595869ecfa2ce7388613dc3161f9

Resolves: tdf#136611 chart doesn't support corner style or caps

It will be available in 7.0.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Aron Budea 2020-12-29 05:50:06 UTC
*** Bug 137435 has been marked as a duplicate of this bug. ***