Download it now!
Bug 136642 - FILEOPEN DOCX Changing Word text box anchoring from Paragraph to Page separates textbox from its shape
Summary: FILEOPEN DOCX Changing Word text box anchoring from Paragraph to Page separat...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+ Master
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: QA:needsComment
Keywords: bibisected, bisected, regression
Depends on: Shape-Textbox
Blocks: DOCX-Textbox
  Show dependency treegraph
 
Reported: 2020-09-10 10:48 UTC by NISZ LibreOffice Team
Modified: 2020-10-22 10:09 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
First shape is anchored to paragraph (146.00 KB, image/png)
2020-09-10 10:48 UTC, NISZ LibreOffice Team
Details
Changing anchor to page and inserting empty paragraph separates the textbox. (62.62 KB, image/png)
2020-09-10 10:49 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2020-09-10 10:48:48 UTC
Created attachment 165352 [details]
First shape is anchored to paragraph

Word-made attachment #165348 [details] contains a shape with text anchored to text.
When this is opened in Writer and the anchor is changed to To page and empty paragraphs are added before it, the text box jumps out ot the shape.


Steps to reproduce:
    1. Open attachment #165348 [details] 
    2. Change the anchoring of the upper shape to To page
    3. Add empty paragraphs after the firs one

Actual results:
The shape stays in place, but its textbox moves downwards.

Expected results:
The shape and the textbox stay in place.

LibreOffice details:
Version: 7.1.0.0.alpha0+ (x64)
Build ID: 34a09c9c61bff30e8c4d16132bb47b2b1b16e422
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win
Locale: hu-HU (hu_HU); UI: en-US
Calc: CL

But not yet in:
Version: 7.0.0.3 (x64)
Build ID: 8061b3e9204bef6b321a21033174034a5e2ea88e
CPU szálak: 4; OS: Windows 6.3 Build 9600; Felületmegjelenítés: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: hu-HU
Calc: CL
Here the shape and textbox moved together a little bit down on each new paragraphs insertion.

Bibisected using bibisect-win64-7.1 to:
URL: https://cgit.freedesktop.org/libreoffice/core/commit/?id=cd384e2d31f74223948ea70d8aa3c318d3ceeb50 

author	Tibor Nagy <nagy.tibor2@nisz.hu>	2020-07-09 09:54:15 +0200
committer	László Németh <nemeth@numbertext.org>	2020-07-15 16:22:38 +0200

tdf#123621 sw: fix textbox position according to DOCX

Adding CC to: Tibor Nagy
Comment 1 NISZ LibreOffice Team 2020-09-10 10:49:21 UTC
Created attachment 165353 [details]
Changing anchor to page and inserting empty paragraph separates the textbox.
Comment 2 NISZ LibreOffice Team 2020-10-22 10:09:53 UTC
This is related to the .uno:SetAnchorToPage command that used to be in the popup menu.
Since 
https://cgit.freedesktop.org/libreoffice/core/commit/?id=09c24681a3414092fde50ec0f617c9f7c79e8a61 

author	Seth Chaiklin <sdc.blanco@youmail.dk>	2020-09-29 18:47:13 +0200
committer	Heiko Tietze <heiko.tietze@documentfoundation.org>	2020-09-30 10:56:57 +0200

tdf#135836 remove "to page" from shape/image contextmenu

This command is not available in the menu, so one is forced to use the Position and Size dialogs controls. Anchoring to page this way the added textbox does not fall out of the shape.
It is still possible to add the .uno:SetAnchorToPage command to the toolbar and changing the anchoring this way still triggers the problem. 

See also: https://bugs.documentfoundation.org/show_bug.cgi?id=84691#c12