Bug 136770 - QR code generator does not work correctly if the properties (URL/Text) are set using a macro
Summary: QR code generator does not work correctly if the properties (URL/Text) are se...
Status: CLOSED DUPLICATE of bug 128779
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
7.0.1.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: QR-code
  Show dependency treegraph
 
Reported: 2020-09-15 12:49 UTC by Juergen Klatt
Modified: 2021-10-22 01:37 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Macro changes position, size and the property URL/Text of the QR-Code (14.09 KB, application/vnd.oasis.opendocument.text)
2020-09-15 12:49 UTC, Juergen Klatt
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Juergen Klatt 2020-09-15 12:49:12 UTC
Created attachment 165521 [details]
Macro changes position, size and the property URL/Text of the QR-Code

Hello,
I have a problem with generating or editing a QR-Code using a macro.

It may be that my macro is faulty or it is a bug in LibreOffice.
A more detailed description including the macro can be found in the attachment.

User profile reset = Yes

tested with: 
A)
Version: 7.0.1.2 (x64)
Build ID: 7cbcfc562f6eb6708b5ff7d7397325de9e764452
CPU threads: 4; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: de-DE
Calc: CL

B)
Version: 7.1.0.0.alpha0+ (x64)
Build ID: b42d55577566b2e6ca96530868a456b111632f94
CPU threads: 4; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: de-DE
Calc: CL

Also I used external QR-Code programms to check the QR-Codes:
A)
Offline Generator and Scanner
CodeTwo QR Code Desktop Reader & Generator 1.1.2.4
https://www.codetwo.com/freeware/qr-code-desktop-reader/?sts=1375

B)
Online  Generator and Scanner
https://webqr.com/

Best Regards

Juergen
Comment 1 Jan-Marek Glogowski 2020-09-15 14:48:25 UTC
The only place generating the SVG of the QR code is currently the QR code dialog (see QrCodeGenDialog::GenerateQRCode, which contains the only call to qrcodegen::QrCode::encodeText). So it's currently impossible to work with QR codes in any automated way.

IMHO a change to the QRCodeProperties should update the SVG.
Comment 2 Juergen Klatt 2020-09-15 15:33:10 UTC
Hello Jan-Marek,

it was a great idea to integrate the QR code generator into LibreOffice, I am sad that it is not possible to control it via a macro.

Is it planned in the future via macro on the QR
Access code generator.

> IMHO a change to the QRCodeProperties should update the SVG.

I've applied this Struct QRCodeProperties in my macro.

When I read out the "Payload" property with MRI / XRAY, the "Payload property" changed by the macro is available, but this does not lead to an SVG update.
The changed property is also displayed in the context menu, but no SVG update takes place

I have described this in my attachment.

Best Regards

Juergen
Comment 3 Roosevelt Price 2021-03-18 08:28:51 UTC Comment hidden (spam)
Comment 4 Mike Kaganski 2021-03-24 09:14:07 UTC

*** This bug has been marked as a duplicate of bug 128779 ***
Comment 5 Oliver jake 2021-10-21 10:08:46 UTC Comment hidden (spam)