Bug 136960 - EDITING: bookmarks cannot be deleted in Bookmark dialogue
Summary: EDITING: bookmarks cannot be deleted in Bookmark dialogue
Status: RESOLVED DUPLICATE of bug 135879
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.1.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: possibleRegression
Depends on:
Blocks: Bookmarks
  Show dependency treegraph
 
Reported: 2020-09-22 20:55 UTC by rpr
Modified: 2020-09-24 21:03 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rpr 2020-09-22 20:55:21 UTC
Description:
New LibreOffice 7.0 Writer has a problem in the Bookmark dialogue opened with Insert > Bookmark: the Delete button is always greyed out and cannot be used for deleting bookmarks present in the document.

Steps to Reproduce:
1. In a new text document write some text and insert a bookmark in the text with Insert > Bookmark > Name: test > Insert > Close.
2. Open the Bookmark dialogue again with Insert > Bookmark.
3. Select the "test" bookmark.

Actual Results:
The Bookmark dialogue has Rename and "Go to" buttons enabled while the Delete button is disabled (greyed out) and cannot be used for deleting the selected bookmark.

Expected Results:
The Delete button should be enabled.


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
Version: 7.0.1.2
Build ID: 00(Build:2)
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3
Ubuntu package version: 1:7.0.1_rc2-0ubuntu0.20.04.1
Comment 2 Dieter 2020-09-23 06:09:32 UTC
I confirm it with

Version: 7.0.1.2 (x64)
Build ID: 7cbcfc562f6eb6708b5ff7d7397325de9e764452
CPU threads: 4; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: threaded
Comment 3 Dieter 2020-09-23 07:08:29 UTC
Bug 135879 perhaps has been fixed this problem. Could you please test?

=> NEEDINFO
Comment 4 Timur 2020-09-23 09:46:22 UTC
Dieter, it's OK that you test with the same version as reporter, but you should test with master immediately after that, when steps are fresh. 

rpr, please test with daily master from https://libreoffice.soluzioniopen.com/daily-version/.
Comment 5 rpr 2020-09-24 21:03:28 UTC
I tested this with version 7.0.3.0.0+ (x64), Build ID: 79b29b6edcdc5ef598056eb1d92084f27cf02f40, and I can confirm that the problem has been fixed.

This bug is actually a duplicate of Bug 135879.
Comment 6 rpr 2020-09-24 21:03:53 UTC

*** This bug has been marked as a duplicate of bug 135879 ***