Download it now!
Bug 137014 - Sidebar: Image section remove red/green/blue/gamma widget
Summary: Sidebar: Image section remove red/green/blue/gamma widget
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: target:7.1.0
Keywords: difficultyBeginner, easyHack, skillCpp, topicUI
: 137831 (view as bug list)
Depends on:
Blocks: Sidebar-UI-UX
  Show dependency treegraph
 
Reported: 2020-09-25 06:56 UTC by andreas_k
Modified: 2020-10-28 20:01 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
remove Red/Green/Blue/Gamma widget from the image sidebar (158.71 KB, image/png)
2020-09-25 06:56 UTC, andreas_k
Details

Note You need to log in before you can comment on or make changes to this bug.
Description andreas_k 2020-09-25 06:56:01 UTC
Created attachment 165824 [details]
remove Red/Green/Blue/Gamma widget from the image sidebar

I propose to remove Red/Green/Blue/Gamma widget from the Image sidebar section. There is a specific toolbar for it and the image toolbar also has only an icon to open the specific toolbar.
Comment 1 Heiko Tietze 2020-09-25 08:17:44 UTC
Purpose of the sidebar is to provide access to the most relevant attributes and functions in order to keep it clean and easy to access. Changing RGB values of an image is at max a secondary function for an office suite and therefore not relevant enough for the sidebar. So a clear +1 for this request.

Code pointer
svx/uiconfig/ui/sidebargraphic.ui
svx/source/sidebar/graphic/GraphicPropertyPanel.cxx 
mxMtrRed, mxMtrGreen, mxMtrBlue
Comment 2 Commit Notification 2020-09-25 16:03:40 UTC
andreas kainz committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/a10585b209c1542ebd2cd0bce6407b8a1c992c48

tdf#137014 Sidebar: Image section remove red/green/blue/gamma

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Jan-Marek Glogowski 2020-10-28 18:08:02 UTC
*** Bug 137831 has been marked as a duplicate of this bug. ***
Comment 4 mwtjunkmail 2020-10-28 19:46:27 UTC
Wow, that just got tedious. Found the color RGB options. Glad to see someone deemed something I use a lot not often used, and the emphasis on "an office suite" sorry, but not sorry, extended well beyond calc and type. You've got more programs in your suite, they should be treated like the part of the suite, not knock-offs earning only secondary consideration.
Comment 5 andreas_k 2020-10-28 20:01:48 UTC
It' not that we removed some functionality.

Sidebar guideline [1]
- Provide access to frequently used features in the sidebar. Make sure to have all features in the dialogs.

[1] https://wiki.documentfoundation.org/Design/Guidelines/SideBar