Download it now!
Bug 137035 - Left page style not allowed when inserting manual break and resetting page numbering to 1.
Summary: Left page style not allowed when inserting manual break and resetting page nu...
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.0.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks:
 
Reported: 2020-09-25 23:05 UTC by dr2867.business
Modified: 2020-10-05 12:21 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Document to test for the bug. (9.46 KB, application/vnd.oasis.opendocument.text)
2020-09-25 23:07 UTC, dr2867.business
Details
Screenshot depicting the issue. (55.51 KB, image/png)
2020-09-25 23:07 UTC, dr2867.business
Details

Note You need to log in before you can comment on or make changes to this bug.
Description dr2867.business 2020-09-25 23:05:07 UTC
Description:
I am writing a technical document that is to be published to PDF.  It is not to be printed.  When I try to insert a manual break and reset the page numbering to 1, the new page is always on the right instead of falling to either right or left.  When I try to force the issue by inserting a manual break and telling it to use the left page and to start the page numbering at 1, it throws an error telling me that I can't do that.

Steps to Reproduce:
1. Create a new document.
2. Go to Format -> Page Styles
3. In the Header tab,
       Turn on the header
       Uncheck "Same content on left/right pages"
       Uncheck "Same content on first page"
4. Goto Insert -> More Breaks -> Manual Break.
       Select Page Break
       Under Page Style, select left page
       Check "Change page number"
       Set new page number to 1.
5. Click OK.
       

Actual Results:
An information box appears explaining that it's not allowed.

Expected Results:
A new page that is on the left side with page number starting at 1.


Reproducible: Always


User Profile Reset: No



Additional Info:
The user profile is not a problem as this computer had Windows installed on it several weeks ago and this is the first time that I'm really using LibreOffice.
Comment 1 dr2867.business 2020-09-25 23:07:00 UTC
Created attachment 165855 [details]
Document to test for the bug.
Comment 2 dr2867.business 2020-09-25 23:07:55 UTC
Created attachment 165856 [details]
Screenshot depicting the issue.
Comment 3 Dieter 2020-09-26 09:34:24 UTC
Tahnk you for reporting the bug. I can confirm the behaviour. You refer to bug 117231. Waht is the difference to that bug? Why do you think, it isn't a duplicate.
=> NEEDINFO
Comment 4 dr2867.business 2020-09-28 19:39:24 UTC
The referred to bug is similar, but not the same.  That bug says it only does it in book view mode (which I wasn't able to find in the menu).  I can confirm that it does it in normal view too, which is the mode that I am using.
Comment 5 Dieter 2020-09-28 20:13:44 UTC
I thought about it, but couldn't find a good solution. And I can hardly imagine a situation where it is clear that a document will never be printed. If you export the document as PDF, it will be very likely, that someone is going to print the document. And even if this is not the case, perhaps somebody will display the PDF document with two pages on the screen. And you should avoid to have odd page numbers on the left (it is wrong).

cc: Design-Team (also to assess, if tis should be treated as duplicate or not)
Comment 6 dr2867.business 2020-09-29 11:38:14 UTC
You make some good points, but shouldn't it be up to the document author and not the development team of the software used to create the document to determine what layout/organization is right or wrong?  If the document author wishes to violate convention, that is their decision.  The development team should not be making that choice for them.

The reason why is that the table of contents for the document is only one page, which has Roman numerals for page numbers.  After that, in the main content of the document, it uses Arabic numerals for page numbers.  The final page, which is the revision history, does not have page numbers.  So if someone does print the document, I would rather not have the person waste resources in printing blank pages which don't really need to be there.
Comment 7 Dieter 2020-09-29 12:38:35 UTC
(In reply to dr2867.business from comment #6)
> You make some good points, but shouldn't it be up to the document author and
> not the development team of the software used to create the document to
> determine what layout/organization is right or wrong?  If the document
> author wishes to violate convention, that is their decision.  The
> development team should not be making that choice for them.

If LO allows users to act against priciple conventions, there will be some bug reports like "LO should forbid users to use odd page numbers on left pages" ;-)
Comment 8 dr2867.business 2020-09-30 08:48:13 UTC
That is true, but you can also make it a checkbox (default checked) option in Tools > Options > LibreOffice Writer > General.  That way LO retains the original functionality, but with the checkbox cleared, it allows one to go against convention.  Other things can check that variable too.  A few if-else type statements to check and modify the code path to forbid a few things or to allow them.
Comment 9 Heiko Tietze 2020-10-05 12:21:42 UTC
Concur with Dieter's WF. Point is that the shipped page style "Left Page" has the layout setting "Only left". You have all freedom to change this, use the style "Right Page", or just create your own.