Bug 137103 - Table in Table in Header deleted upon saving the document
Summary: Table in Table in Header deleted upon saving the document
Status: RESOLVED DUPLICATE of bug 135942
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.1.2 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Writer-Header-Footer
  Show dependency treegraph
 
Reported: 2020-09-28 16:08 UTC by wed
Modified: 2020-10-06 12:54 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description wed 2020-09-28 16:08:59 UTC
Description:
Create a two column table in the header.
Create a two row table in the right column.
Save & close document.
Open document.
Second table is gone.

Steps to Reproduce:
0. Open emtpy document.
1. Create a two column table in the header.
2. Create a two row table in the right column.
3. Save & close document.
4. Open document.

Actual Results:
Second table is gone.

Expected Results:
Second table should NOT be deleted upon saving.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.0.1.2
Build ID: 00(Build:2)
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: de-DE (de_DE.UTF-8); UI: de-DE
Ubuntu package version: 1:7.0.1_rc2-0ubuntu0.18.04.1
Calc: threaded
Comment 1 Telesto 2020-09-28 21:52:47 UTC
No repro with
Version: 7.0.0.2
Build ID: c01aa64b6c3d89ebe5fe69c28c7adb24eb85249c
CPU threads: 4; OS: Mac OS X 10.12.6; UI render: default; VCL: osx
Locale: nl-NL (nl_NL.UTF-8); UI: en-US
Calc: threaded
Comment 2 BogdanB 2020-09-29 05:49:52 UTC
Repro with saving as ODF

Version: 7.0.1.2 (x64)
Build ID: 7cbcfc562f6eb6708b5ff7d7397325de9e764452
CPU threads: 4; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win
Locale: ro-RO (ro_RO); UI: en-US
Calc: threaded
Comment 3 BogdanB 2020-09-29 05:56:54 UTC
When saving as DOC or DOCX don't repro
Comment 4 BogdanB 2020-09-29 06:30:35 UTC
Don't repro if the same table is in the content of the document. So I consider to be a header bug.
Comment 5 wed 2020-09-29 07:58:18 UTC
This also happens to older documents created with older versions.
That's why I noticed - 7.0.1.2 deleted these tables from my older documents.
The table doesn't disappear upon saving - only when the document is opend again.
So it's a problem with the saved dcoument.

Inside the ODT container the header is stored in the file "styles.xml".
Inside this file the tables are stored in xml format.
As far as I can tell
the second table is still present - but has lost it's content.
Comment 6 raal 2020-09-29 16:51:17 UTC
no repro with Version: 7.1.0.0.alpha0+
Build ID: cd85546a2fbdade42f80fd3b6bd650791db9f32d
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3
Locale: cs-CZ (cs_CZ.UTF-8); UI: en-US
Calc: threaded
Comment 7 BogdanB 2020-09-29 18:19:58 UTC
I tested like this:

I don't repro in:
Version: 7.1.0.0.alpha0+
Build ID: cd85546a2fbdade42f80fd3b6bd650791db9f32d
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: ro-RO (ro_RO.UTF-8); UI: en-US
Calc: threaded

I don't repro in:
Version: 7.0.2.0.0+
Build ID: b27137a7091104cce177791478e86d127680c9af
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: ro-RO (ro_RO.UTF-8); UI: en-US
Calc: threaded

but I REPRO in:
Version: 7.0.1.2
Build ID: 7cbcfc562f6eb6708b5ff7d7397325de9e764452
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-US (ro_RO.UTF-8); UI: en-US
Calc: threaded

I will bibisect now.
Comment 8 BogdanB 2020-09-29 18:32:46 UTC
In 7.0 everything was good when bibisecting. I don't understand why... I have done reverse bibisecting (good for bad and bad for good, and I mark all of them as bad in this case, becase I knew taht was solved in 7.0.2.
Comment 9 Timur 2020-09-30 07:46:15 UTC
How I did it. Change must've been in master recently, tried master~1000 OK, tried master~1000 NOK, so bisect in between, headless will do, single command:

git bisect start master~1000  master~2000  &&  instdir/program/soffice   --headless    --convert-to odt   --outdir   ~/Documents/     /LibreOffice_Bug/137103\ test.odt      &&   instdir/program/soffice  ~/Documents/137103\ test.odt 

commit 42416f1393df4a6bb3ab315e490b781cc1d43d89
Date:   Fri Aug 21 14:31:22 2020 +0200
    source sha:f0286ad82465152b29bba01ab2edeb97291397fa
    previous source sha:5dffb7ba361ad76aa249d6c93fd87fff67362726

commit	f0286ad82465152b29bba01ab2edeb97291397fa	[log]
author	Mike Kaganski <mike.kaganski@collabora.com>	Fri Aug 21 00:15:29 2020 +0300
committer	Mike Kaganski <mike.kaganski@collabora.com>	Fri Aug 21 14:18:35 2020 +0200
tree	3c65146183ea46f00130ff831ada53b5e50ef212
parent	5dffb7ba361ad76aa249d6c93fd87fff67362726 [diff]

tdf#135942: avoid collecting autostyles during writing them 

Looks like Mike fixed it - great.
Comment 10 BogdanB 2020-09-30 07:49:37 UTC
Will be this change available in the next 7.0?...
Comment 11 Timur 2020-09-30 09:19:58 UTC
Bogdan, you see bug 135942 and backport to 7.0.2, not clear what you ask.
Comment 12 BogdanB 2020-09-30 16:48:10 UTC
(In reply to Timur from comment #11)
> Bogdan, you see bug 135942 and backport to 7.0.2, not clear what you ask.

Yes, this was what I asked for, if this would be backport to 7.0.2.
Thank you, Timur.

For the reporter of this bug: 7.0.2 will be release before 11 octomber 2020, so this version will ba safe for opening your files.
Comment 13 wed 2020-10-01 08:54:05 UTC
I thank everybody involved for their effort!
Well done! :-)
Comment 14 Xisco Faulí 2020-10-06 12:54:50 UTC
No need for a test, the unittest in https://git.libreoffice.org/core/+/f0286ad82465152b29bba01ab2edeb97291397fa%5E%21 already checks there are 2 tables after exporting the document to ODT
@Timur, thanks for the reverted bisection

*** This bug has been marked as a duplicate of bug 135942 ***