Bug 137135 - [1] #VALUE Errors in IFS and SWITCH functions
Summary: [1] #VALUE Errors in IFS and SWITCH functions
Status: CLOSED DUPLICATE of bug 111675
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1 all versions
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-09-29 18:37 UTC by Vincent
Modified: 2020-09-30 10:14 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Different test for the bug (10.64 KB, application/octet-stream)
2020-09-29 18:54 UTC, Vincent
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vincent 2020-09-29 18:37:08 UTC
Description:
Hi,

The Result of both IFS and SWITCH functions are #VALUE error for the second result when the first result is an #VALUE error, even if the second result is good and is the one that should be shown.

Steps to Reproduce:
1.Enter in a case:
2.=SWITCH(2;1;YEAR("");2;YEAR(41244);)
3.=SWITCH(2;1;IFS("tset";1);2;YEAR(41244))

Actual Results:
#VALUE

Expected Results:
2012 which is the RESULT of YEAR(41244)


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 7.0.1.2 (x86)
Build ID: 7cbcfc562f6eb6708b5ff7d7397325de9e764452
CPU threads: 2; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: default; VCL: win
Locale: fr-FR (fr_FR); Langue IHM : fr-FR
Calc: threaded
Comment 1 Vincent 2020-09-29 18:54:07 UTC
Created attachment 165953 [details]
Different test for the bug
Comment 2 Vincent 2020-09-29 18:58:39 UTC
It seems that the bug is happenning only with conditions:
For SWITCH: happen only when the result is a function, and when the error value is in the function not out (in an other cell)
For IFS: When the previous result is a function with an error value (not in an other cell)and when the result that should be sowed need a logical test.
Comment 3 Xisco Faulí 2020-09-29 19:29:36 UTC
Reproduced in

Version: 7.1.0.0.alpha0+
Build ID: cd85546a2fbdade42f80fd3b6bd650791db9f32d
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

and

Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)

@Eike, I thought you might be interested in this issue
Comment 4 Eike Rathke 2020-09-30 10:13:50 UTC

*** This bug has been marked as a duplicate of bug 111675 ***