Bug 137211 - My "EXACT" function isn't working properly, but only with one specific spreadsheet.
Summary: My "EXACT" function isn't working properly, but only with one specific spread...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-10-02 16:15 UTC by R.J. Bowman
Modified: 2020-10-02 16:45 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments
A sample file affected by the bug (22.73 KB, application/vnd.oasis.opendocument.spreadsheet)
2020-10-02 16:17 UTC, R.J. Bowman
Details

Note You need to log in before you can comment on or make changes to this bug.
Description R.J. Bowman 2020-10-02 16:15:28 UTC
Description:
This is a specific problem with a spreadsheet. I have cut the spreadsheet down to just a portion of the entries effected and you can download it here:
http://wonderworldcomics.com/ProblemEXACTFunction.ods
The problem is that the "EXACT" function isn't working properly. It always returns a "FALSE" result, even when comparing two cells with the exact same contents.
I'm using LebreOffice 7.0.1.2, but it doesn't matter. The problem appeared when I was using an earlier version. I thought that an update might fix it, but it didn't. I checked the file on a different computer and the bug was still there. The same file even produces the same results on OpenOffice Calc, so the problem is likely to be present on just about any version of LibreOffice or OpenOffice.
If I save the sheet in CSV format then reload, the problem is fixed in the new CSV file, but then if I copy the sheet from the CSV file and past it into a new sheet in the ODS file, the problem comes back.
I think that it has something to do with the formatting of the sheet, but I've tried everything I could think of and, no dice.
Please advise.

Steps to Reproduce:
1. Load file that I've linked to
2. Look at what the functions in column 1 are doing

Actual Results:
Always false, even when it should be true. Only with this one spreadsheet.

Expected Results:
Should have resulted in true when cells compared matched.


Reproducible: Always


User Profile Reset: No



Additional Info:
The bug seems to exist in all LibreOffice software versions, and even in OpenOffice.
Comment 1 R.J. Bowman 2020-10-02 16:17:36 UTC
Created attachment 166042 [details]
A sample file affected by the bug
Comment 2 Mike Kaganski 2020-10-02 16:41:55 UTC
Which cell exactly is expected to produce TRUE?
Comment 3 Mike Kaganski 2020-10-02 16:45:54 UTC
Ah, this is not a bug. Your ODS has Data->Calculate->AutoCalculate disabled. It just does not calculate formulas, until you press F9 (for current cell) or Ctrl+Shift+F9 (for everything).