Bug 137242 - FILESAVE DOCX: "-1" parameter Offset value for footer changes to "0"
Summary: FILESAVE DOCX: "-1" parameter Offset value for footer changes to "0"
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.1.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: DOCX-Header-Footer Fields-Page-Number DOCX-Fields
  Show dependency treegraph
 
Reported: 2020-10-04 14:58 UTC by yousifjkadom
Modified: 2021-06-11 07:00 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
pageNumbering.odt: document setup as described in repro steps- now export as DOCX. (9.87 KB, application/vnd.oasis.opendocument.text)
2020-12-05 18:04 UTC, Justin L
Details
The Page number field settings in Word (49.94 KB, image/png)
2021-06-11 06:55 UTC, NISZ LibreOffice Team
Details
How to set page numbering offset in Word/Writer (98.33 KB, image/png)
2021-06-11 06:59 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description yousifjkadom 2020-10-04 14:58:42 UTC
Description:
I have docx. file composed from 16 pages, a theses. The 1st page is a cover (title & my name). I like to add page number as footer. I like to start the count from 2nd page to be numbered as "1" (I mean that I like to leave the cover not numbered).

Steps to Reproduce:
1. go to inferior sector of page
2. click "add footer"
3. select "format footer" & uncheck "same content on 1st page" then save.
4. select "Insert Page Number", then set Offset at "-1", then add it.
5. save docx. & exit
6. re-open the document.

Actual Results:
when add "Insert Page Number" after set "Offset" to "-1", the numbers started from 2nd page (leave 1st page "cover") without number & started the number from 2nd page counting it as 1, then to other pages as 3, 4, 5, .... as I like very okay.
But after save changed & closing the docx. file then re-open it the Offset value revert to default "0" & numbering of page, though started from 2nd page, but not started by number 1 ! It started from number 2 !

Expected Results:
The numbering of page should remain start from 2nd page as 1, then for next pages as 2, 3, 4, 5, ......


Reproducible: Always


User Profile Reset: No



Additional Info:
I'm using flatpak package from FlatHub on my Fedora Linux 32 X64 bit Cinnamon edition.
Comment 1 Dieter 2020-10-06 06:28:55 UTC
I confirm it with

Version: 7.0.2.2 (x64)
Build ID: 8349ace3c3162073abd90d81fd06dcfb6b36b994
CPU threads: 4; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win
Locale: he-IL (de_DE); UI: en-GB
Calc: threaded
Comment 2 Justin L 2020-12-05 18:04:49 UTC
Created attachment 167852 [details]
pageNumbering.odt: document setup as described in repro steps- now export as DOCX.

I cannot reproduce in master or in 6.4.7.

Also, the -1 is IMMEDIATELY changed to a zero. If you look at the paragraph properties again, you will see that your -1 has already turned into a zero. So it has nothing to do with saving as DOCX.
Comment 3 Justin L 2020-12-05 18:11:57 UTC
OK - I got lost on the "set offset at -1. (you got that by double-clicking on the page number field.)

The proper way to specify the page number is to edit the page break properties. You can either find this on the page break dotted line, or typically find on the first paragraph after a page break. For the very first page, you find it on the first paragraph's paragraph properties - Text flow. In there you see the option to set page style and Page number. (Setting it to -1 here changes it back to zero immediately.)
Comment 4 NISZ LibreOffice Team 2021-06-11 06:55:23 UTC
Created attachment 172788 [details]
The Page number field settings in Word

I don't think there is any setting for the page number field in Word that could be the equivalent of the Offset field in Writer.

Page numbering offset can be set in the Format - Title page dialog of Writer and there is an equivalent of that in Word on the Header / footer settings ribbon under the Page number dropdown - Format page numbering. Those are already interoperable.
Comment 5 NISZ LibreOffice Team 2021-06-11 06:59:46 UTC
Created attachment 172789 [details]
How to set page numbering offset in Word/Writer