Download it now!
Bug 137285 - Annoying flash/flicking when playing presentation
Summary: Annoying flash/flicking when playing presentation
Status: RESOLVED DUPLICATE of bug 122737
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.2.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-10-06 07:53 UTC by Telesto
Modified: 2020-10-12 19:29 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-10-06 07:53:36 UTC
Description:
Annoying flash/flicking when playing presentation

Steps to Reproduce:
1. Open attachment 166114 [details]
2. Press F5
3. Notice the flashing/flickering

Actual Results:
Flickering with Skia/GDI. OpenGL drops to desktop

Expected Results:
Flicker free experience


Reproducible: Always


User Profile Reset: No



Additional Info:
Found in
7.1

and in
Version: 6.2.0.0.alpha0+
Build ID: 9d754a59154c40235c240bb0e7f47a2006fa85bd
CPU threads: 4; OS: Windows 6.3; UI render: GL; 
Locale: nl-NL (nl_NL); Calc: CL

fine in
4.4.7.2
Comment 1 Telesto 2020-10-06 07:57:38 UTC
Also in
6.0

5.2
Comment 2 Telesto 2020-10-06 07:59:39 UTC
also in 
5.2
Comment 3 Timur 2020-10-06 08:37:38 UTC
I don't know what's best to do, to ignore zillion of Telesto bugs, or to deprive him of reporting bugs or to endlessly spend time marking duplicates.

*** This bug has been marked as a duplicate of bug 91456 ***
Comment 4 Telesto 2020-10-06 13:04:58 UTC
(In reply to Timur from comment #3)
> I don't know what's best to do, to ignore zillion of Telesto bugs, or to
> deprive him of reporting bugs or to endlessly spend time marking duplicates.
> 
> *** This bug has been marked as a duplicate of bug 91456 ***

Not everything you assume to be a duplicate is actually a duplicate. Yes, I'm guilty of reporting some duplicates. Similar to you being guilty of marking non-duplicates as duplicates (or even at the wrong bug). And you miss out responses about that (I assume, because you never add yourself to a CC list) 

And mystery how this can be a duplicated of a bug bibisected in different range 

There a probably 2 or 3 issues on top of each other (so same type of symptoms, same area, different cause). Can't help it. Would love it where more simple; but this is simply not true. 

And FWIW, I do think fade smooth is actually working (which also stated in bug 91456). So bug 91456 actually solved a long time ago (maybe reintroduced.. and maybe different issues on Linux side). But those are actually different bug; not that of the initial poster. So it looks to me that people are sadly hijacking bug 91456. So there issues snow under.. in a bug report where those issue don't belong. 

FWIW: I do know Aron bibisected a flickering bug related to presentation mode somewhere between LibO 4.4.7.2 LibO 5.1. And I assumed it should be solved by buffering (Skia). However it also appeared at OpenGL some while later (which like closed; no OpenGL). And Skia uses OpenGL code paths (as far I'm aware).
Comment 5 Xisco Faulí 2020-10-12 17:27:52 UTC
@Aron, is it possible you reported as similar issue in the past ?
Comment 6 Telesto 2020-10-12 19:29:41 UTC
I did report this already apparently.. However I think I see 2 flashes here, but lets say it's a dupe of bug 122737

*** This bug has been marked as a duplicate of bug 122737 ***