Bug 137397 - Faulty Height value in Position and Size content panel in Properties deck in the sidebar in Calc
Summary: Faulty Height value in Position and Size content panel in Properties deck in ...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.1.0 target:7.0.4
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2020-10-11 15:00 UTC by Regina Henschel
Modified: 2020-11-19 13:51 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot of the faulty Height field (24.29 KB, image/png)
2020-10-11 15:00 UTC, Regina Henschel
Details
file with custom row height (7.03 KB, application/vnd.oasis.opendocument.spreadsheet)
2020-10-14 16:39 UTC, Regina Henschel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Regina Henschel 2020-10-11 15:00:44 UTC
Created attachment 166269 [details]
Screenshot of the faulty Height field

Start Calc and draw a shape. While shape is selected open 'Properties' deck of sidebar and there open 'Position and Size' content panel. Look at the 'Height' field. Its value is broken, see attached screenshot.

I see the error in Version: 7.1.0.0.alpha0+ (x64)
Build ID: 7aaa9ef2e5edaf468f116449776433e98fb1a2f3
CPU threads: 8; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win
Locale: de-DE (en_US); UI: en-US
Calc: threaded

It is OK in Version: 7.0.0.2 (x64)
Build ID: c01aa64b6c3d89ebe5fe69c28c7adb24eb85249c
CPU threads: 8; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win
Locale: de-DE (en_US); UI: en-US
Calc: CL
Comment 1 Xisco Faulí 2020-10-12 17:16:43 UTC
Not reproducible in

Version: 7.1.0.0.alpha0+
Build ID: a9976a958b2857e308c6598532151878615bfd9f
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: x11
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 2 Regina Henschel 2020-10-14 16:39:57 UTC
Created attachment 166367 [details]
file with custom row height

The problem seems to be connected with setting a custom row height. o

Open attached empty file. It has row height 15mm and column width 25mm. Draw a shape and look at the Height field in the side bar.
Comment 3 pavlog 2020-11-10 19:04:38 UTC
I can't reproduce in 

Version: 7.0.3.1 (x64)
Build ID: d7547858d014d4cf69878db179d326fc3483e082
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: Skia/Vulkan; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: CL
Comment 4 Buovjaga 2020-11-18 09:45:29 UTC
(In reply to Regina Henschel from comment #2)
> Created attachment 166367 [details]
> file with custom row height
> 
> The problem seems to be connected with setting a custom row height. o
> 
> Open attached empty file. It has row height 15mm and column width 25mm. Draw
> a shape and look at the Height field in the side bar.

I repro, but not with gtk3.

Bibisected with linux64-7.0 repo to
https://git.libreoffice.org/core/commit/c85fcc6e1994eb8e079aaca85066ab4d67149c15
weld PosSizePropertyPanel

Adding Cc: to Caolán McNamara
Comment 5 Xisco Faulí 2020-11-18 12:26:05 UTC
I can reproduce it when using centimeters but not inches. I haven't tested with other units
Comment 6 Commit Notification 2020-11-18 15:42:02 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/1f904541c780207ccb37d1ef41f8b897e50c58cf

tdf#137397 Faulty Height value in Position and Size content panel

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Caolán McNamara 2020-11-18 15:42:53 UTC
fixed in master, backport to 7-0 in gerrit
Comment 8 Commit Notification 2020-11-18 20:21:15 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/a930f12c30f31d306ba60c5344cd8308d9fa4ee1

tdf#137397: sc: Add UItest

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2020-11-19 01:19:10 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/2b433a52c164558b85ec85b6b8ccf6b11776695c

tdf#137397 Faulty Height value in Position and Size content panel

It will be available in 7.0.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.