Download it now!
Bug 137481 - Insert "Formula" command in Writer appears twice for different UNO commands in Customize Keyboard
Summary: Insert "Formula" command in Writer appears twice for different UNO commands i...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.1.2 release
Hardware: All All
: medium enhancement
Assignee: Rafael Lima
URL:
Whiteboard: target:7.2.0
Keywords: difficultyBeginner, easyHack, skillDesign, topicDesign
: 138405 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-10-14 17:21 UTC by Rafael Lima
Modified: 2020-12-02 16:06 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Image describing the problem (120.97 KB, image/png)
2020-10-14 17:21 UTC, Rafael Lima
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rafael Lima 2020-10-14 17:21:22 UTC
Created attachment 166368 [details]
Image describing the problem

Users who often insert Math formulas into their documents tend to assign a shortcut to the "Insert" > "Formula" function using the Customize > Keyboard dialog.

The problem is that the same "Formula" label is used for two different commands in Writer. I attached an image showing exactly what I am talking about.

The first "Formula" is associated with the uno:InsertFormula command whereas the second "Formula" is associated with the uno:InsertObjectStarMath command.

It would be better to use different labels for each function. For example, the first could be named "Insert Calculated Field" and the second could be "Insert Math Formula".

I would like to point out that this issue does not only occur with "Formula", but also with other commands such as "Comment" that also appears twice for two different commands.
Comment 1 Mike Kaganski 2020-10-14 17:32:53 UTC
To help disambiguating these, tdf#108458 added popups in the lists of customization dialog, showing UNO commands and descriptions (tooltips).
Comment 2 Rafael Lima 2020-10-14 17:53:14 UTC
Hi Mike!

In the case of the "Formula" commands, the tooltips were not enough for me to understand what each command meant.

Also, I do not see it as a problem to have a clearer and unambiguous label for these commands.

Maybe someone could conduct a review of these tooltips, because the tooltips of most commands are just copies of the command names.
Comment 3 Mike Kaganski 2020-10-14 18:00:49 UTC
(In reply to Rafael Lima from comment #2)

No objections of course; you might had noticed that I didn't close the issue, just added a See Also reference, and commented for the context ;-)
Comment 4 Rafael Lima 2020-10-14 18:13:10 UTC
(In reply to Mike Kaganski from comment #3) 
> No objections of course; you might had noticed that I didn't close the
> issue, just added a See Also reference, and commented for the context ;-)

I would volunteer to help with this issue, but I have never submitted a patch to the LibreOffice code. I downloaded it, but I still don't know how to find the part of the code where this is located. Are these names and tooltips located in a separate XML file?

I have good knowledge of Python programming and can get around with C++. Is there some sort of "mentoring" program to get started developing LibreOffice patches?
Comment 5 Heiko Tietze 2020-10-16 11:59:48 UTC
.uno:InsertFormula inserts a plain formula / math expression (most common in Calc but also available in Writer and very usful for tables)
.uno:InsertObjectStarMath adds the OLE object from the Math module

This requires some rephrasing. Tooltips are easy but we should also think about better short names for the function in order to distinguish in menus.

(In reply to Rafael Lima from comment #4)
> I would volunteer to help with this issue...

That's great. Changing strings is easy hackable, I'll add code pointers when we have decided what it should become.
Comment 6 Heiko Tietze 2020-10-22 13:24:02 UTC
We discussed the request in the design meeting and suggest to use "(Insert) Text formula" for .uno:InsertFormula (math expression) / F2 and "(Insert) Formula object" for .uno:InsertObjectStarMath (Math module).

Blog post at https://design.blog.documentfoundation.org/2018/02/28/easyhacking-all-about-terminology/ explains how to change the labels. 

The commands are defined at officecfg/registry/data/org/openoffice/Office/UI/WriterCommands.xcu and core/officecfg/registry/data/org/openoffice/Office/UI/CalcCommands.xcu
Comment 7 Mike Kaganski 2020-11-22 11:55:35 UTC
*** Bug 138405 has been marked as a duplicate of this bug. ***
Comment 8 Commit Notification 2020-12-02 16:06:03 UTC
Rafael Lima committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/5b464179c19310504e5a6f900811b7cc523120b6

Resolves tdf#137481: Changes the "Formula" labels in Writer/Calc/Draw/Impress

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.