Bug 137522 - Ability to save settings for importing data to Calc
Summary: Ability to save settings for importing data to Calc
Status: RESOLVED DUPLICATE of bug 74580
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks:
 
Reported: 2020-10-16 07:45 UTC by Frants
Modified: 2020-11-19 12:44 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Frants 2020-10-16 07:45:56 UTC
Description:
It is necessary to add the ability to save the settings for importing data into Calc. When importing many text files with different data structures, it is inconvenient to configure the import parameters in the "Text Import" window each time. It is more convenient to load the specification with the settings that were previously used into the "Text Import" window.  Such a function would be useful.

Actual Results:
Saving user time.

Expected Results:
Saving user time.


Reproducible: Always


User Profile Reset: No



Additional Info:
Unspecified
Comment 1 m.a.riosv 2020-10-17 19:53:06 UTC
If I'm not wrong the last used remains. And making the link permanent the imported files can be updated through Menu/Edit/Link to external files, and every file keeps their own import configuration.
Comment 2 Frants 2020-10-18 16:43:38 UTC
Yes, you are right, my proposal is not relevant. You mean the import path is Sheet -> Link to External Data? Still, an ordinary user needs to know about this path. Not all users know about this when they use the File → Open (* .txt) path. For example, in the question "How to remove automatic field separators in text import in Calc". In such a case, in the "Text Import" window, a link or option for using the "Sheet -> Link to External Data" mechanism would be useful. Maybe it would improve usability?
https://ask.libreoffice.org/en/question/211141/how-to-remove-automatic-field-separators-in-text-import-in-calc/
Comment 3 Heiko Tietze 2020-11-19 12:44:21 UTC
Issue is solved, similar/same discussion runs on bug 74580

*** This bug has been marked as a duplicate of bug 74580 ***