Bug 137528 - Arabic Letters are sometimes disjoined and the vowel marks are misplaced in justified paragraph in Text Box
Summary: Arabic Letters are sometimes disjoined and the vowel marks are misplaced in j...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.0.3 release
Hardware: All Windows (All)
: medium normal
Assignee: خالد حسني
URL:
Whiteboard: target:7.5.0 inReleaseNotes:7.5
Keywords:
Depends on:
Blocks: Kashida-Justification
  Show dependency treegraph
 
Reported: 2020-10-16 12:11 UTC by M. S. Rosyidi
Modified: 2022-12-07 16:37 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Arabic Letter in Text Box with Justified Alignmen (15.32 KB, application/vnd.oasis.opendocument.text)
2020-10-16 12:11 UTC, M. S. Rosyidi
Details
Screenshoot using Amiri Font (150.91 KB, image/png)
2020-10-16 12:12 UTC, M. S. Rosyidi
Details
Screenshoot using Scheherazade Font (114.54 KB, image/png)
2020-10-16 12:13 UTC, M. S. Rosyidi
Details
Gaps with LO 7.5 dev output (14.18 KB, application/pdf)
2022-10-02 20:06 UTC, Hossein
Details

Note You need to log in before you can comment on or make changes to this bug.
Description M. S. Rosyidi 2020-10-16 12:11:23 UTC
Created attachment 166412 [details]
Arabic Letter in Text Box with Justified Alignmen

Arabic letter in Text Box with justified alignment are sometimes disjoined.
Comment 1 M. S. Rosyidi 2020-10-16 12:12:20 UTC
Created attachment 166413 [details]
Screenshoot using Amiri Font
Comment 2 M. S. Rosyidi 2020-10-16 12:13:04 UTC
Created attachment 166414 [details]
Screenshoot using Scheherazade Font
Comment 3 M. S. Rosyidi 2020-10-16 12:17:16 UTC
There is similar problem https://bugs.documentfoundation.org/show_bug.cgi?id=106653 and it may be has been solved but it not in Tex Box so I think the problem I reported here is different
Comment 4 Dieter 2021-05-02 10:54:15 UTC
I confirm it with

Version: 7.1.3.1 (x64) / LibreOffice Community
Build ID: fa76d07d7006a0e2866c3247cef2d5eb55ae8369
CPU threads: 4; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: de-DE
Calc: threaded

Steps to reproduce:
1. Open attachment 166412 [details]
2. Compare text in TextBox with text ouside TextBox (see attachment 166413 [details]) => Text in textbox has some mistakes
3. Copy text from texbox and paste it outside => Misteakes disappear
Comment 5 Commit Notification 2022-08-14 19:11:32 UTC
Khaled Hosny committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/640a2bc1cd093875b701bb958b6156d5752c0fac

tdf#137528: Sync Kashida algorithm in editeng with sw

It will be available in 7.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Dieter 2022-10-02 14:11:56 UTC
Comparing text in textbox with text outside I can see only one problem solved (third line)

Version: 7.5.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: c3b5eea4304ad6815b491f549fce008a9630c213
CPU threads: 4; OS: Windows 10.0 Build 19044; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: CL threaded

=> REOPENED
Comment 7 Hossein 2022-10-02 20:06:17 UTC
Created attachment 182792 [details]
Gaps with LO 7.5 dev output

Reproduced with the latest LO 7.5 dev master:

Version: 7.5.0.0.alpha0+ / LibreOffice Community
Build ID: 57ecd472d7078f9e540cccd4873355d6250fc21f
CPU threads: 8; OS: Linux 5.15; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

There were several of these in the console output:

warn:vcl.gdi:100273:100273:vcl/source/gdi/CommonSalLayout.cxx:828: Asked to insert Kashidas in a font with bogus Kashida width
Comment 8 خالد حسني 2022-10-02 20:49:11 UTC
(In reply to Hossein from comment #7)
> Created attachment 182792 [details]
> Gaps with LO 7.5 dev output
> 
> Reproduced with the latest LO 7.5 dev master:
> 
> Version: 7.5.0.0.alpha0+ / LibreOffice Community
> Build ID: 57ecd472d7078f9e540cccd4873355d6250fc21f
> CPU threads: 8; OS: Linux 5.15; UI render: default; VCL: gtk3
> Locale: en-US (en_US.UTF-8); UI: en-US
> Calc: threaded
> 
> There were several of these in the console output:
> 
> warn:vcl.gdi:100273:100273:vcl/source/gdi/CommonSalLayout.cxx:828: Asked to
> insert Kashidas in a font with bogus Kashida width


Oops. I was testing with unreleased version of Amiri that has Kashida glyph (released versions has a hack for bad Kashida insertion in LibreOffice that recent code changes made it unnecessary), so I missed a typo in the code.
Comment 9 Commit Notification 2022-10-02 23:40:45 UTC
Khaled Hosny committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/9063d99ff5ee43cc1239fc1dbb5d9897bdda1c9b

tdf#137528: Fix skipping Kashida in fonts with bogus ones

It will be available in 7.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Hossein 2022-10-03 04:16:33 UTC
Verified fix with the above patch.

The problem was not visible in the latest LO 7.5 dev master:

Version: 7.5.0.0.alpha0+ / LibreOffice Community
Build ID: bb67f10786fd5e232b198d09139c41078c3fc60d
CPU threads: 8; OS: Linux 5.15; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded