Bug 137584 - OpenPGP keys not found LibreOffice 7 on macOS 10.15 Catalina
Summary: OpenPGP keys not found LibreOffice 7 on macOS 10.15 Catalina
Status: RESOLVED DUPLICATE of bug 115538
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
7.0.2.2 release
Hardware: All macOS (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-10-19 07:50 UTC by Jeff Holloway
Modified: 2020-10-19 07:58 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jeff Holloway 2020-10-19 07:50:36 UTC
Description:
Running LibreOffice 7.0.2.2 on Mac OS 10.15.7 with GPGTools 2020.1.

No PGP keys/signatures are found when LibreOffice is started from Launchpad, Spotlight or directly via double click on ODF file.

This is both visible in the settings when no predefined PGP key can be chosen, and in the signature dialog, when no PGP is offered.

Starting LibreOffice via "open /Applications/LibreOffice.app", or "open file.odt" or "/Applications/LibreOffice.app/Contents/MacOS/soffice" does find the key.

Steps to Reproduce:
1. Open LibreOffice
2. Go to Preferences -> LibreOffice -> User Data -> Cryptography

Actual Results:
Only option displayed is "No Key"

Expected Results:
Ability to select predefined OpenPGP key


Reproducible: Always


User Profile Reset: Yes



Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: StartModule
[Information guessed from browser]
OS: Mac OS X (All)
OS is 64bit: no
Comment 1 Alex Thurgood 2020-10-19 07:58:42 UTC

*** This bug has been marked as a duplicate of bug 115538 ***