Bug 137610 - FILEOPEN DOCX Date/time fields from O365 open as English locale
Summary: FILEOPEN DOCX Date/time fields from O365 open as English locale
Status: RESOLVED DUPLICATE of bug 99236
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: DOCX-Fields
  Show dependency treegraph
 
Reported: 2020-10-20 06:40 UTC by NISZ LibreOffice Team
Modified: 2022-03-14 08:30 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file from Word 365 with all default date/time fields (26.02 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2020-10-20 06:40 UTC, NISZ LibreOffice Team
Details
Screenshot of the O365 document side by side in Word 2013 and Writer (161.53 KB, image/png)
2020-10-20 06:41 UTC, NISZ LibreOffice Team
Details
Example file from Word 2013 with all default date/time fields (27.14 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2020-10-20 06:43 UTC, NISZ LibreOffice Team
Details
Screenshot of the Word2013 document side by side in Word and Writer (93.05 KB, image/png)
2020-10-20 06:43 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2020-10-20 06:40:47 UTC
Created attachment 166523 [details]
Example file from Word 365 with all default date/time fields

Attached file was made in a Hungarian O365 Word to demonstrate all the default date/time field formats.
When opened in Writer all fields appear in English locale despite the document language is Hungarian.
A similar document made in Word 2013 opens correctly with Hungarian locale.

Steps to reproduce:
    1. Open attached document.

Actual results:
English date formats.

Expected results:
Hungarian date formats.

LibreOffice details:
Version: 7.1.0.0.alpha0+ (x64)
Build ID: f558d810de845ad1dd52632ca0a2cae4733ed6e6
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: en-US
Calc: CL

Also in:
Version: 6.0.0.3
Build ID: 64a0f66915f38c6217de274f0aa8e15618924765
CPU threads: 4; OS: Windows 6.3; UI render: default; 
Locale: en-US (hu_HU); Calc: CL

Version: 5.0.0.5
Build ID: 1b1a90865e348b492231e1c451437d7a15bb262b
Locale: hu-HU (hu_HU)

Verzió: 4.0.0.3 (Build az.: 7545bee9c2a0782548772a21bc84a9dcc583b89)

LibreOffice 3.5.0rc3 
Build ID: 7e68ba2-a744ebf-1f241b7-c506db1-7d53735
Comment 1 NISZ LibreOffice Team 2020-10-20 06:41:54 UTC
Created attachment 166524 [details]
Screenshot of the O365 document side by side in Word 2013 and Writer
Comment 2 NISZ LibreOffice Team 2020-10-20 06:43:03 UTC
Created attachment 166525 [details]
Example file from Word 2013 with all default date/time fields
Comment 3 NISZ LibreOffice Team 2020-10-20 06:43:19 UTC
Created attachment 166526 [details]
Screenshot of the Word2013 document side by side in Word and Writer
Comment 4 Mike Kaganski 2020-10-20 06:58:36 UTC
An example from word/document.xml from MSO365 (attachment 166523 [details]):

>        <w:p w:rsidR="00A318AE"
>               w:rsidRDefault="00962DF6">
>            <w:r>
>                <w:fldChar w:fldCharType="begin"/>
>            </w:r>
>            <w:r>
>                <w:instrText xml:space="preserve"> TIME \@ "yyyy. MM. dd." </w:instrText>
>            </w:r>
>            <w:r>
>                <w:fldChar w:fldCharType="separate"/>
>            </w:r>
>            <w:r>
>                <w:rPr>
>                    <w:noProof/>
>                </w:rPr>
>                <w:t>2020. 09. 22.</w:t>
>            </w:r>
>            <w:r>
>                <w:fldChar w:fldCharType="end"/>
>            </w:r>
>        </w:p>

A similar piece from MSO2013 (attachment 166525 [details]):

>        <w:p w:rsidR="00DD5159"
>               w:rsidRDefault="00DD5159">
>            <w:pPr>
>                <w:rPr>
>                    <w:lang w:val="hu-HU"/>
>                </w:rPr>
>            </w:pPr>
>            <w:r>
>                <w:fldChar w:fldCharType="begin"/>
>            </w:r>
>            <w:r>
>                <w:rPr>
>                    <w:lang w:val="hu-HU"/>
>                </w:rPr>
>                <w:instrText xml:space="preserve"> TIME \@ "yyyy.MM.dd." </w:instrText>
>            </w:r>
>            <w:r>
>                <w:fldChar w:fldCharType="separate"/>
>            </w:r>
>            <w:r>
>                <w:rPr>
>                    <w:noProof/>
>                    <w:lang w:val="hu-HU"/>
>                </w:rPr>
>                <w:t>2020.09.22.</w:t>
>            </w:r>
>            <w:r>
>                <w:fldChar w:fldCharType="end"/>
>            </w:r>
>        </w:p>

Look at all those <w:lang w:val="hu-HU"/> from the latter, that are absent in the former.
And here comes the question: what are the locale settings in your LibreOffice, that are rightfully used when the document does not provide the language information.

Likely NAB.
Comment 5 Mike Kaganski 2020-10-20 07:07:17 UTC
On the other hand, MS Word 2016 shows Hungarian dates in those fields on my Windows (Russian locale, English UI), even after refresh, so the language information likely exists somewhere else in the file.
Comment 6 Justin L 2022-03-14 08:30:00 UTC
Sounds like a duplicate of bug 99236.

*** This bug has been marked as a duplicate of bug 99236 ***