Bug 137616 - JumpLists for LO shortcuts in Windows are deleted every time LO is updated.
Summary: JumpLists for LO shortcuts in Windows are deleted every time LO is updated.
Status: RESOLVED DUPLICATE of bug 76131
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-10-20 10:28 UTC by Jones
Modified: 2020-10-20 11:00 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jones 2020-10-20 10:28:32 UTC
Description:
JumpLists in Windows are a very handy feature to quickly open documents, because they contain manually user pinned files as well as auto populated other recently opened files.

But with every update installation of LO the JumpLists are deleted and the users have to rebuild them manually, which is annoying, because this time consuming process has to be repeated with every update installation of LO.

JumpLists for all programs (not only LibreOffice) are stored in this path: "C:\Users\USERNAME\AppData\Roaming\Microsoft\Windows\Recent\AutomaticDestinations". For example the JumpList configuration file for LO Writer is "d38a3ea7ec79fbed.automaticDestinations-ms", the file for LO Calc is "83dd64e7fa560bd5.automaticDestinations-ms".

With every update installation of LO those files are deleted and the JumpList is lost.

This is NOT A BUG OF WINDOWS, because when I update other programs, the JumpLists of those prorgams stay the way they are. Instead, this annoying situation is caused by the non-optimal way LO does the update process: complete de-installation and then re-installaion of LO. Because when a program gets de-installed, windows also deletes all the associated config files (which is a good thing, because this ensured the hard drive to stay uncluttered).


Solution:
In order to not delete all the associated configuration files for the JumpLists, the LO update process must be optimised for the Windows operating system.

Steps to Reproduce:
1. Download the LO installer
2. Install/Update LO
3. Have your JumpList entries deleted

Actual Results:
see above

Expected Results:
see above


Reproducible: Always


User Profile Reset: No



Additional Info:
see above
Comment 1 Mike Kaganski 2020-10-20 10:58:50 UTC

*** This bug has been marked as a duplicate of bug 76131 ***