Bug 137662 - When combo box (and List box) from Base is located in a data sheet, it has to be clicked twice in order to be able to enter text
Summary: When combo box (and List box) from Base is located in a data sheet, it has to...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
7.0.0.3 release
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.2.0 target:7.1.0.0.beta2 tar...
Keywords: regression
Depends on:
Blocks:
 
Reported: 2020-10-21 16:52 UTC by Milston B.
Modified: 2020-11-25 13:03 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Open the form and move through it by tabulator. Try to change values in combobox. (12.36 KB, application/vnd.oasis.opendocument.database)
2020-10-22 15:17 UTC, Robert Großkopf
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Milston B. 2020-10-21 16:52:17 UTC
Description:
Since the update to version 7.0.0.3 from LibreOffice the behavior from the combo box and the list box in an data sheet has changed.

Before 7.0.0.3 you were able to enter text with one click on it or when you jumped to it with tabulator.
Now you have to "activate" it with an extra mouse click which renders the navigation per keyboard ad absurdum.

Steps to Reproduce:
1. Create a Base formular with a data sheet which contains a list box and/or a combo box
2. Conntect it io an table (this should be a no brainer but i burnt my fingers with that kind of assumptions more than once)
3a. Click on the combo-/list box once and try to enter text
3b. Jump to the combo-/list box with tabulator and try to enter text

Actual Results:
The combo-/list box gets highlighted. Thats it.
You have to click on it (a second time, when highlighted witch mouse click) to enter text

Expected Results:
After clicking on it once or jumping to it with tabulator you should be able to enter text immediately (As it was bevore 7.0.0.3)


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
I have this bug on two seperate machines:

No.1 -- Workplace
     Version: 7.0.1.2 (x86)
     Build ID: 7cbcfc562f6eb6708b5ff7d7397325de9e764452
     CPU threads: 4; OS: Windows 10.0 Build 17763; UI render: Skia/Raster; VCL: win
     Locale: de-DE (de_DE); UI: de-DE

No.2 -- At home
     Version: 7.0.2.2
     Build ID: 00(Build:2)
     CPU threads: 4; OS: Linux 5.9; UI render: default; VCL: gtk3
     Locale: de-DE (de_DE.UTF-8); UI: de-DE
     7.0.2-2
     Calc: threaded
Comment 1 Robert Großkopf 2020-10-22 15:15:44 UTC
Could confirm the buggy behavior, also for VCL: kf5 on OpenSUSE 15.1 64bit rpm Linux. Works in LO 6.4.6.2, fails in LO 7.0.2.2, so a regression

Note: You can't get out of the listbox or combobox by tabulator if you activated it by mouse, if you are using VCL: gtk3 inside a tablecontrol with LO 7.0.2.2 Another bug?
Comment 2 Robert Großkopf 2020-10-22 15:17:06 UTC
Created attachment 166637 [details]
Open the form and move through it by tabulator. Try to change values in combobox.
Comment 3 Milston B. 2020-10-22 20:39:03 UTC
(In reply to Robert Großkopf from comment #1)
> [...]
> Note: You can't get out of the listbox or combobox by tabulator if you
> activated it by mouse, if you are using VCL: gtk3 inside a tablecontrol with
> LO 7.0.2.2 Another bug?

Oh! You are right. I didn't notice that behavior, because i select the combo box since the update with a double click.
Comment 4 Julien Nabet 2020-11-21 19:21:15 UTC
(In reply to Robert Großkopf from comment #1)
> Could confirm the buggy behavior, also for VCL: kf5 on OpenSUSE 15.1 64bit
> rpm Linux. Works in LO 6.4.6.2, fails in LO 7.0.2.2, so a regression
> 
> Note: You can't get out of the listbox or combobox by tabulator if you
> activated it by mouse, if you are using VCL: gtk3 inside a tablecontrol with
> LO 7.0.2.2 Another bug?

On pc Debian x86-64 with master sources updated today + gtk3, after having select listbox with mouse, I can use tabulator to go to the next field.
If I click on the arrow, I must first type Escape key to show only the selected entry.
However, I can select a value in listbox manually once in it with a tabulator, I would have expected top/bottom arrows to select an entry of the listbox.

Also I noticed that, only after having expanded a listbox, this log appears each time I use tabulator:
** (soffice:908352): WARNING **: 20:12:49.048: Focused object has invalid index in parent

BTW, no better with gen rendering except that top/bottom arrows in list box just move the cursor at previous/next row, so again impossible to select another entry of the listbox without mouse (or missed it).

Caolán: not specific gtk3, but thought you might be interested in this one since it may be related to vcl/welding process?
Comment 5 Caolán McNamara 2020-11-23 11:09:03 UTC
I think there might be two semi-related bugs in here
Comment 6 Caolán McNamara 2020-11-23 11:38:52 UTC
https://gerrit.libreoffice.org/c/core/+/106414 for the gen problem
Comment 7 Caolán McNamara 2020-11-23 11:44:21 UTC
and
https://gerrit.libreoffice.org/c/core/+/106245
for the remaining problem that I see specific to gtk
Comment 8 Commit Notification 2020-11-23 14:35:12 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/21ad89c4d4fe630cb132c4b396a58a38d3408396

tdf#137662 ignore focus in dropdown if dropdown is hidden

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Caolán McNamara 2020-11-23 14:40:24 UTC
I think this is now good in master, and backports of relevant pieces are in gerrit for 7-1 and 7-0
Comment 10 Commit Notification 2020-11-23 15:18:00 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/e1488697f01ea80f2e835e600b4498f8b34003fe

tdf#137662 ignore focus in dropdown if dropdown is hidden

It will be available in 7.1.0.0.beta2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2020-11-24 14:08:15 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/cd9cbb072f7dee244e8ed71ad9372f15067b69b6

tdf#137662 ignore focus in dropdown if dropdown is hidden

It will be available in 7.0.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2020-11-25 13:03:48 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/6911ac40f668895089d4ae4de90edba95e283433

tdf#137662 set focus in combo/list box on click

It will be available in 7.0.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.