Bug 137726 - Message dialog during pivot table insertion not displayed, LO hangs
Summary: Message dialog during pivot table insertion not displayed, LO hangs
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.0.0.3 release
Hardware: All All
: medium major
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.1.0 target:7.0.4
Keywords: bibisected, bisected, regression
: 138154 (view as bug list)
Depends on:
Blocks: Pivot-Table
  Show dependency treegraph
 
Reported: 2020-10-25 07:25 UTC by Aron Budea
Modified: 2020-11-12 12:23 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2020-10-25 07:25:58 UTC
- Start LO with "gen" VCL plugin (SAL_USE_VCLPLUGIN=gen ./soffice) or in Windows.
- In Calc, open Data -> Pivot Table -> Insert or Edit...
- Press OK twice (in Select Source and in Pivot Table Layout).

=> A message dialog is supposed to come up (in front of the Pivot Table Layout dialog), but instead the previous dialog disappears, and the Calc UI is locked up, nothing can be done.

With GTK3 VCL plugin the message dialog appears, but it's not in focus (and the Pivot Table Layout dialog that previously was shown in the background disappears as well).

Observed using LO 7.1.0.0.alpha0+ (f1d798151048dde3f48b124ef406416668d1e9c5), 7.0.0.3 / Ubuntu, Windows.
No issue in 6.4.0.3.
=> regression

Bibisected to the 7.0 backport of the following commit using repo bibisect-linux-64-7.0. Adding CC: to Caolán McNamara.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=ebc2bbba2558dd6fe5cb41b453514211d1fb0c1c
author		Caolán McNamara <caolanm@redhat.com>	2020-07-09 15:07:38 +0100
committer	Caolán McNamara <caolanm@redhat.com>	2020-07-09 16:59:48 +0200

tdf#134688 run error dialog async and keep the events in the one event loop
Comment 1 m.a.riosv 2020-10-25 11:02:41 UTC
Confirmed
Version: 7.1.0.0.alpha0+ (x64)
Build ID: a34caaa3e68bb8acadb4051481ceeedcb6827b27
CPU threads: 4; OS: Windows 10.0 Build 20180; UI render: Skia/Raster; VCL: win
Locale: es-ES (es_ES); UI: en-US
Calc: CL
Comment 2 Caolán McNamara 2020-10-27 15:25:52 UTC
I think its parent is set as the parent of the dialog that is being dismissed
Comment 3 Commit Notification 2020-10-27 19:47:03 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/9f2daed124829717b9350b78ac301a0b9fceacf8

tdf#137726 hide pivot table dlg so its not a candidate as error dlg parent

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Caolán McNamara 2020-10-27 19:47:44 UTC
works for me in master, backport to 7-0 in gerrit
Comment 5 Commit Notification 2020-10-28 08:22:36 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/585f8dacba798afde6b4cc439c969a37a37e6162

tdf#tdf#137726: sc: Add UItest

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 m.a.riosv 2020-10-28 11:11:17 UTC
Verified
Version: 7.1.0.0.alpha1+ (x64)
Build ID: a4d4ed86991e2901ac86189e95966d4e99be4944
CPU threads: 4; OS: Windows 10.0 Build 20180; UI render: Skia/Raster; VCL: win
Locale: es-ES (es_ES); UI: en-US Calc: CL
Comment 7 Commit Notification 2020-10-29 10:53:22 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/b7eef4e6242d8ef803d1789cf1c44e2f8bc9ceee

tdf#137726 hide pivot table dlg so its not a candidate as error dlg parent

It will be available in 7.0.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Xisco Faulí 2020-11-12 12:23:13 UTC
*** Bug 138154 has been marked as a duplicate of this bug. ***