Bug 137749 - Implement INT Writer's table function for Word's table interoperability
Summary: Implement INT Writer's table function for Word's table interoperability
Status: RESOLVED DUPLICATE of bug 123381
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: DOCX-Tables Writer-Tables-Formulas
  Show dependency treegraph
 
Reported: 2020-10-25 22:24 UTC by Roman Kuznetsov
Modified: 2022-04-26 09:14 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
INT table function DOCX example (10.01 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2020-10-25 22:24 UTC, Roman Kuznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Kuznetsov 2020-10-25 22:24:03 UTC
Description:
Implement INT Writer's table function for Word's table interoperability

Steps to Reproduce:
1. Open DOCX file from attach
2. Look at error message in right table cell
3. There is a formula =INT(A1) in that cell and it must show a result 12 instead an error message

Actual Results:
we have only an error message instead of a result of formula

Expected Results:
we have implemented function INT and we have a correct result in table cell with a formula


Reproducible: Always


User Profile Reset: No



Additional Info:
-
Comment 1 Roman Kuznetsov 2020-10-25 22:24:41 UTC
Created attachment 166715 [details]
INT table function DOCX example
Comment 2 Roman Kuznetsov 2020-10-25 22:33:41 UTC
László, possibly you will be interesting in it
Comment 3 Roman Kuznetsov 2020-10-26 16:35:57 UTC
Regina, should this Writer table function be in ODF standard? If yes, how can I add it to next version ODF draft?
Comment 4 Dieter 2021-05-12 06:57:57 UTC
(In reply to Roman Kuznetsov from comment #3)
> Regina, should this Writer table function be in ODF standard? If yes, how
> can I add it to next version ODF draft?

Regina what can you say about it?
Comment 5 Gabor Kelemen (allotropia) 2022-04-26 09:14:07 UTC
This was just implemented in:

https://git.libreoffice.org/core/+/27953931d4f6a8c69b98a90c63db81ebb27cdf63

author	Xisco Fauli <xiscofauli@libreoffice.org>	Fri Apr 15 22:17:01 2022 +0200
committer	László Németh <nemeth@numbertext.org>	Fri Apr 22 14:44:42 2022 +0200

tdf#123381: sw: add table formula INT

*** This bug has been marked as a duplicate of bug 123381 ***