Bug 137873 - Remove "For the current document only" from Tools > Options > Language (as per comment 3)
Summary: Remove "For the current document only" from Tools > Options > Language (as pe...
Status: RESOLVED DUPLICATE of bug 103036
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-10-30 11:13 UTC by Heiko Tietze
Modified: 2020-11-10 14:03 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Heiko Tietze 2020-10-30 11:13:50 UTC
As follow-up to bug 96988: Users seems to be confused by this option. The recommended workflow is using Tools > Language (and/or templates, styles etc.) while the option defines the default.
Comment 1 Mike Kaganski 2020-10-30 11:54:26 UTC
(In reply to Heiko Tietze from comment #0)

Is there a way to set the document language? Currently Tools->Language->For All Text->More goes to the said Tools > Options > Language, with the "For the current document only" checkbox checked. What is the substitution, before that thing is removed?
Comment 2 Heiko Tietze 2020-10-30 12:12:12 UTC
Didn't test T>L but this should just set the language for the document as T>O>L does. So it's not just removing the checkbox, unfortunately.
Comment 3 Mike Kaganski 2020-10-30 13:14:03 UTC
Actually all three - "For Selection"/"For Paragraph"/"For All Text" - lead to confusing dialogs. Former two bring the Character dialog on Font tab, where language is just one setting among multiple. The latter one brings the said Language dialog... where the language is also not the only thing; and all that is rather counter-intuitive, and inconsistent.

I would propose to implement this in stages:

1. Create a dedicated "Set Language" dialog, with the only purpose to select the text language. It would be very simple: have only one list box with languages, OK and Cancel. It would be consistently used for all three actions.

2. When it's implemented, the checkbox (and related document-specific functionality) may be removed from Options.

This would duplicate functionality a bit: Character dialog has the control to set the language, doing the same as this proposed dialog; yet, having a streamlined UI for the *dedicated* UNO command seems logical, and convenient to end user. If needed, the dialog and/or its help could include the mention that this is the same thing that is available on Character dialog (for selection and Paragraph cases).

What do you think?
Comment 4 Heiko Tietze 2020-10-30 13:32:30 UTC
(In reply to Mike Kaganski from comment #3)
> What do you think?

+1 (statusbar offers to set installed languages per single click, menu probably too; this needs to be considered; and the new dialog's selection is taken from the current selection).
Comment 5 Heiko Tietze 2020-11-10 12:46:01 UTC
No further input, let's do it.
Comment 6 Heiko Tietze 2020-11-10 13:06:31 UTC

*** This bug has been marked as a duplicate of bug 103036 ***
Comment 7 V Stuart Foote 2020-11-10 14:03:37 UTC
+1