Bug 137887 - wrong help page linked to Help button in Position and Size dialog for Textbox and Shape
Summary: wrong help page linked to Help button in Position and Size dialog for Textbox...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.4.0
Keywords:
Depends on:
Blocks: Help-Link
  Show dependency treegraph
 
Reported: 2020-10-30 19:23 UTC by sdc.blanco
Modified: 2022-04-06 14:22 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sdc.blanco 2020-10-30 19:23:14 UTC
1. Insert shape or textbox.
2. Right-click, choose "Position and Size"
3. Press help button in Position and Size tab.

Actual Result:  Goes to Type page for Format Image (and Frame)
https://help.libreoffice.org/7.1/en-US/text/swriter/01/05060100.html

Expected:  Should go to: Position and Size for Format - Textbox and Shape  https://help.libreoffice.org/7.1/en-US/text/shared/01/05230100.html 

Also confirmed in: https://bugs.documentfoundation.org/show_bug.cgi?id=137141#c9
Comment 1 pavlog 2020-11-24 20:59:59 UTC
Thank you for reporting the bug. I can confirm that the bug is present in
Version: 7.1.0.0.alpha1+ (x64)
Build ID: 91c5642bf0ee48ff91181d779c3a84c768f340df
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: Skia/Vulkan; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: CL
Comment 2 Rafael Lima 2021-03-31 19:58:55 UTC
I've just tested it in LO 7.1.2.2 and this is happenning only in Writer. In Impress/Draw and Calc everything is fine.

Seems to be just a matter of adding the correct HID to the help file.
Comment 3 Rafael Lima 2021-03-31 20:22:01 UTC
There's a caveat here. If you look closely, the "Position and Size" menu in Writer is different from the menu in Impress, Calc and Draw.

Also, the "Type" tab in the "Properties" menu of objects and frames (in Writer) is identical to the "Position and Size" dialog in Writer. So that's why the Help button for the "Position and Size" dialog lands here:

https://help.libreoffice.org/7.1/en-US/text/swriter/01/05060100.html?System=UNIX&DbPAR=WRITER&HID=cui/ui/swpossizepage/SwPosSizePage#bm_id3147407

(note the SW in swPosSizePage - which indicates that it's Writer specific)

In short, the Help button is landing in the right help page, but the reason why it feels weird is that the title of the Help page is simply "Type" instead of "Position and Size".

So we do not need to change the HID, but instead improve the 05060100.xhp by:
1) changing it's title to something hybrid as "Position and Size / Type" or simply "Position and Size" which is more descriptive
2) Update the "To access this command" section of the Help page to include the "Context menu > Position and size" option
Comment 4 sdc.blanco 2021-03-31 22:16:39 UTC
(In reply to Rafael Lima from comment #3)
> So we do not need to change the HID, but instead improve the 05060100.xhp by:
This page (05060100.xhp) is for Image.

The OP is for text box and shape in Writer.  (Calc/Draw/Impress have a different Position/Size dialog for textbox/shape).
ยจ
(look at the "To access this command" description for each page)
Comment 5 Rafael Lima 2022-01-03 17:48:07 UTC
Indeed, the help page should be:
https://help.libreoffice.org/7.4/en-US/text/shared/01/05230100.html

The fix will also need to consider pressing F1 in each element of the dialog.
Comment 6 Commit Notification 2022-01-04 12:14:01 UTC
Rafael Lima committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/082a62657dc9e89dc54c3299e47dd1f76c4c9de1

tdf#137887 Fix help links for Position and Size dialog