Bug 137891 - Escape chart mode after Insert > Chart
Summary: Escape chart mode after Insert > Chart
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.3.1 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: accessibility, needsUXEval
Depends on:
Blocks: Chart-Wizard
  Show dependency treegraph
 
Reported: 2020-10-31 01:37 UTC by TorrAB
Modified: 2020-11-27 10:06 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description TorrAB 2020-10-31 01:37:58 UTC
French version. New file. Insertion menu. Hit ‘d’, get diagramme.
Then, you cannot remove it with either Delete or ^z. Why?
Comment 1 Dieter 2020-11-17 09:21:19 UTC
I confirm it

Steps to reproduce
1. Open a new document
2. Insert => Chart

Result: Chart wizard appears and it is not possible to press Strg+Z or Del

Not sure, if this is the intended behaviour or not
=> cc: Design-Team

I think the main problem is, that moste of the users (including me) are not aware that they see the chart wizard. (bug 90307 will probably solve this problem)
Comment 2 Heiko Tietze 2020-11-17 09:39:13 UTC
You are in the chart module- and self-destruction is not possible. Would resolve the ticket as WF but unlike coming from the inserted chart via double-click it's not possible to leave this mode per escape (and press delete then).

To make it more clear that another module is active we could auto-select the chart area (right now nothing is selected), which updates the sidebar and hides Navigator or Stylist or whatever was selected before.

Perhaps we solve the missing escape option by this, at least doing it manually does work. Until then the workaround is to press F6 until the chart type becomes active, down to get the chart area, 2x escape, and delete.
Comment 3 Dieter 2020-11-17 09:52:02 UTC
(In reply to Heiko Tietze from comment #2)
> You are in the chart module

Yes, and that's not obvious for unexperienced user (but as I stated before, that's another topic)
Comment 4 Heiko Tietze 2020-11-27 10:06:41 UTC
Tested again with 7.0.3 under Windows and 7.2 under Linux. Both allow to leave the chart mode with escape and to delete the object then. Depending on whether a chart element is selected or not you have to press one or two times escape. This is a minor inconsistency.

Resolving the issue as WFM since it was a problem when I tried the first time but isn't anymore.