Bug 137923 - "Clone Formatting" disabled on some elements which can take cloned formats
Summary: "Clone Formatting" disabled on some elements which can take cloned formats
Status: RESOLVED DUPLICATE of bug 117646
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
7.0.2.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Clone-Formatting
  Show dependency treegraph
 
Reported: 2020-11-01 23:00 UTC by Eyal Rozenberg
Modified: 2020-11-28 16:56 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eyal Rozenberg 2020-11-01 23:00:22 UTC
I've recent used Clone Formatting on some arrow objects in a presentation of mine. I've noticed that when selecting some (individual) arrows - the Clone Formatting button is disabled. This, despite the fact that these arrows are quite formattable, and I am able to apply "Clone Formatting" to them from other arrows.

I think the arrows for which this happens are the "fancy" ones, i.e. having two right-turns, or a curved path, rather than going straight between the endpoints.

Version: 7.0.2.2
Build ID: 8349ace3c3162073abd90d81fd06dcfb6b36b994
CPU threads: 4; OS: Linux 5.2; UI render: default; VCL: gtk3
Locale: he-IL (en_IL); UI: en-US
Comment 1 pavlog 2020-11-27 20:15:45 UTC
Thank you for reporting the bug. 
Unfortunately without clear steps to reproduce it, we cannot track down the origin of the problem. 
Please provide a clearer set of step-by-step instructions on how to reproduce the problem.
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested information is provided.
Comment 2 Eyal Rozenberg 2020-11-27 22:12:23 UTC
(In reply to pavlog from comment #1)

It seems that you repeat this comment - the whole block - verbatim on different bugs. That makes me wonder: Have you tried reproducing this issue based on my description of when it occurs?

If you have, and couldn't, then I'll spell it out more explicitly; for now, returning to UNCONFIRMED.
Comment 3 pavlog 2020-11-28 07:22:44 UTC
I've tried to repro it with different kinds of arrows but no success. If it's no Linux connected issue it will help if you could specify the exact symbols you have problem with. So now I can't reproduce it in my environment.
Comment 4 Eyal Rozenberg 2020-11-28 10:51:08 UTC
(In reply to pavlog from comment #3)
Ok, fair enough I guess. Well:

1. Create a new Impress document
2. Ensure the drawing toolbar is enabled
3. Insert a "Connector ends with arrow" from the connectors menubutton (just place it anywhere on the slide, it doesn't matter)
4. Insert a line using the "Insert line" button (again, place it anywhere)
5. Select the line you inserted.
6. Observe the state of the "Clone Formatting" button on the main toolbar
7. Select the two-right-angle-turns connector you inserted. 
8. Observe the state of the "Clone Formatting" button on the main toolbar

Expected results: 

The "Clone formatting" button is active/usable in both steps 6 and 8.

Actual results:

The "Clone formatting" button is active/usable in step 6, but inactive/grayed-out in step 8.
Comment 5 pavlog 2020-11-28 16:52:27 UTC
(In reply to Eyal Rozenberg from comment #4)

Thank you for clarification. Suppose it's a duplicate of tdf#117646

*** This bug has been marked as a duplicate of bug 117646 ***
Comment 6 pavlog 2020-11-28 16:56:54 UTC
I can repro it in

Version: 7.1.0.0.alpha1+ (x64)
Build ID: 91c5642bf0ee48ff91181d779c3a84c768f340df
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: Skia/Vulkan; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: CL