Download it now!
Bug 138240 - ODBC: Crash when trying to connect to Edit → Database → Properties (gtk3)
Summary: ODBC: Crash when trying to connect to Edit → Database → Properties (gtk3)
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
7.0.3.1 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.1.0 target:7.0.4
Keywords: haveBacktrace
: 138266 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-11-15 17:27 UTC by Robert Großkopf
Modified: 2020-11-28 19:17 UTC (History)
3 users (show)

See Also:
Crash report or crash signature: crashreport.libreoffice.org/stats/crash_details/df84468c-973d-455d-9a83-bebc4e0012b5


Attachments
bt with debug symbols (7.69 KB, text/plain)
2020-11-15 19:42 UTC, Julien Nabet
Details
screenshot of the charset combobox (with gen rendering) (26.51 KB, image/png)
2020-11-15 20:13 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Großkopf 2020-11-15 17:27:13 UTC
This bug appears in LO 7.0.3.1, not in LO 6.4.6.4 an older versions.

Open any database, which is connected to Base through ODBC.
Try to see Edit → Database  → Properties
LO crashes immediately.

Tested here with Firebird and ODBC, also with PostgreSQL and ODBC on OpenSUSE 15.1 64bit rpm Linux.

crashreport.libreoffice.org/stats/crash_details/df84468c-973d-455d-9a83-bebc4e0012b5
Comment 1 Julien Nabet 2020-11-15 19:40:52 UTC
On pc Debian x86-64 with master sources updated today + ODBC Postgresql, I could reproduce this.
It seems specific to gtk3.
Indeed, if I do:
export SAL_USE_VCLPLUGIN=gen;soffice --base

I don't reproduce the crash.
Comment 2 Julien Nabet 2020-11-15 19:42:47 UTC
Created attachment 167317 [details]
bt with debug symbols
Comment 3 Julien Nabet 2020-11-15 19:45:08 UTC
Caolán: thought you might be interested in this once since it's specific to gtk3.
Comment 4 Julien Nabet 2020-11-15 20:13:17 UTC
Created attachment 167318 [details]
screenshot of the charset combobox (with gen rendering)
Comment 5 Commit Notification 2020-11-16 14:52:02 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/99f4e625cdd6384291ccde1f68dca73ced43edfb

Resolves: tdf#138240 GtkComboBox without model

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Caolán McNamara 2020-11-16 14:52:48 UTC
fixed in master, backport to 7-0 in gerrit
Comment 7 Julien Nabet 2020-11-16 19:48:41 UTC
On pc Debian x86-64 with master sources updated today, I don't reproduce this anymore.

Thank you Caolán!
Comment 8 Commit Notification 2020-11-17 16:06:22 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/0c624a5c4af585633611b46fd800d1d87b2984bc

Resolves: tdf#138240 GtkComboBox without model

It will be available in 7.0.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Terrence Enger 2020-11-17 19:17:06 UTC
*** Bug 138266 has been marked as a duplicate of this bug. ***