Bug 138264 - Calc Wrong number of selected rows if there's an AutoFilter
Summary: Calc Wrong number of selected rows if there's an AutoFilter
Status: RESOLVED DUPLICATE of bug 84517
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.4.7.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-11-16 17:24 UTC by Josete
Modified: 2020-11-16 18:55 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Josete 2020-11-16 17:24:46 UTC
Description:
When there's an aufilter active and a selection the status bar
shows a wrong number of selected rows if between the first and the last are filtered rows.


Steps to Reproduce:
1. Activate autofilter.
Let's say this filter hides lines 4 and 5
2. Make a selection from lines 3 to 6


Actual Results:
The status bar shows "Selected: 4"

Expected Results:
The status bar shows "Selected: 2"


Reproducible: Always


User Profile Reset: No



Additional Info:
It seems that Calc counts from the first row to the last including all the hidden lines. In this case, from 3 to 6 there are 4 rows, but there are only 2 rows selected.
Despite this bad behabiour, if you make a change to the 2 selected rows, only those 2 rows will be affected which is perfect.
Comment 1 m.a.riosv 2020-11-16 18:55:24 UTC

*** This bug has been marked as a duplicate of bug 84517 ***