Bug 138294 - FILEOPEN DOCX: Formula in cells in all but the first table in document corrupted by saving and reopening document.
Summary: FILEOPEN DOCX: Formula in cells in all but the first table in document corrup...
Status: RESOLVED DUPLICATE of bug 122648
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.3.1 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: dataLoss
Depends on:
Blocks: DOCX-Formula Writer-Tables-Formulas
  Show dependency treegraph
 
Reported: 2020-11-17 20:24 UTC by Peter
Modified: 2021-02-24 14:43 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Writer document with two tables with a forumla i them. (7.44 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2020-11-17 20:24 UTC, Peter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Peter 2020-11-17 20:24:34 UTC
Created attachment 167377 [details]
Writer document with two tables with a forumla i them.

Steps to reproduce.

1) Create a writer document with a table include a forumla. (for instance the one attached)

2) save and reopen and confirm the forumla still shows the correct result.

3) Duplicate the table so you have two tables, one above the other, both containing a working formula.

4) Save and reopen - The formula in the first table will still be working find, but the identical formula in the second table will have been currpted. Normally displaying as '** Expression is faulty **', If you inspect the formula you will see all the cell reference are brocken:

Working formula: '=  <A2>*<B2>*<C2>*<D2>'
Corrupted Formula: '=    L ? G * L ? G * L ? G * L ? G '
Comment 1 Dieter 2020-12-03 07:10:16 UTC
I confirm it with

Version: 7.0.3.1 (x64)
Build ID: d7547858d014d4cf69878db179d326fc3483e082
CPU threads: 4; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: CL

If I open file in Word 2016, it shows correct result
Comment 2 Timur 2020-12-03 11:20:26 UTC
This confirmation means there was a bug. But to know if there still is, must be tested with LO master. In this case even more, because there some similar bugs are fixed. 
Dieter, you are here for long and you know that. And testing with master is easy, both installing master from the link I put, or using SI-GUI for download and extraction. 
Please test from https://dev-builds.libreoffice.org/daily/master/current.html.
Comment 3 Dieter 2020-12-03 11:42:32 UTC
(In reply to Timur from comment #2)
> This confirmation means there was a bug. But to know if there still is, must
> be tested with LO master.

I can't find that information here: https://wiki.documentfoundation.org/QA/BugTriage Where can I find that information. Please help me.

You've changed bug status to NEEDINFO: This meens (regarding to https://bugs.documentfoundation.org/page.cgi?id=fields.html#bug_status): "The report is not complete to determine whether the described problem is a bug and we need additional information or actions from the reporter." I don't see that this is the case here => Back to NEW

> In this case even more, because there some similar
> bugs are fixed.

Would be nice, if you could refer to them.
 
> Dieter, you are here for long and you know that. And testing with master is
> easy, both installing master from the link I put, or using SI-GUI for
> download and extraction. 
> Please test from
> https://dev-builds.libreoffice.org/daily/master/current.html.

For some reasons, it's not possible for me to install master on every computer I use. I will test on another computer during the next days.
Comment 4 Dieter 2020-12-04 07:57:48 UTC
It seems to be fixed recently, because I can't reproduce it in

Version: 7.1.0.0.alpha1+ (x64)
Build ID: 10b23330a9655658e6d7ef1d008a3302a15e9629
CPU threads: 4; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: threaded

Peter, could you also please try to reproduce it with a master build from http://dev-builds.libreoffice.org/daily/master/current.html ? You can install it alongside the standard version. I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the master build. Change it to RESOLVED WORKSFORME, if the problem has gone away.
Comment 5 Timur 2021-02-24 14:19:45 UTC
WorksForMe, both DOCX and DOC in LO and MSO. 
Needs to be tested with ODT,attached docx is corrupted.
Comment 6 Timur 2021-02-24 14:43:38 UTC
Of course, this was fixed by Laszlo in bug 122648, as I indicated.

*** This bug has been marked as a duplicate of bug 122648 ***