Bug 138481 - Support for multiple code point emojis is missing
Summary: Support for multiple code point emojis is missing
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Tor Lillqvist
URL:
Whiteboard: target:7.2.0 target:7.1.0.0.beta2 tar...
Keywords:
Depends on:
Blocks:
 
Reported: 2020-11-25 10:49 UTC by Tor Lillqvist
Modified: 2020-12-05 18:49 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample document (8.65 KB, application/vnd.oasis.opendocument.text)
2020-11-25 10:49 UTC, Tor Lillqvist
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tor Lillqvist 2020-11-25 10:49:23 UTC
Description:
LibreOffice is not able to display emojis like 👨🏼‍🎨 . (See https://emojipedia.org/man-artist-medium-light-skin-tone/ . It consists of four code points: 👨 Man, 🏼 Medium-Light Skin Tone, ‍ Zero Width Joiner and 🎨 Artist Palette.

Steps to Reproduce:
Try the attached document. 

Actual Results:
👨🏼‍🎨 shows up as separate man and palette glyphs.

Expected Results:
👨🏼‍🎨 shows up correctly.


Reproducible: Always


User Profile Reset: No



Additional Info:
Tried with current master on Fedora 33 and macOS.
Comment 1 Tor Lillqvist 2020-11-25 10:49:53 UTC
Created attachment 167556 [details]
Sample document
Comment 2 Tor Lillqvist 2020-11-25 13:08:37 UTC
(I tried using both Noto Emoji and Emoji One as the font on Linux.)
Comment 3 Tor Lillqvist 2020-11-25 13:09:41 UTC
Ha! On macOS, if I use the Apple Color Emoji font, it works!
Comment 4 Tor Lillqvist 2020-11-25 20:17:43 UTC
Suggested fix in https://gerrit.libreoffice.org/c/core/+/106632 . But it might be the wrong way to fix the problem, let's see what the reviewers say.
Comment 5 Tor Lillqvist 2020-11-26 12:16:12 UTC
(More detailed discussion about this in Gerrit.)
Comment 6 Commit Notification 2020-11-27 07:24:16 UTC
Tor Lillqvist committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/8578a1c9d167c19f1d8038fac5946b4b3cae305e

tdf#138481: Trust the built-in break iterator character data in ICU

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2020-11-27 12:00:43 UTC
Tor Lillqvist committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/27efeeb7a80c84dbe243f2301f1dbf10cff7ce8d

tdf#138481: Trust the built-in break iterator character data in ICU

It will be available in 7.1.0.0.beta2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Kevin Suo 2020-11-27 14:20:07 UTC
Tor Lillqvist: I see you are working on this issue by yourself, so I set it as ASSIGNED. Would you please set it to RESOLVED FIXED if the issue is fixed.
Comment 9 Tor Lillqvist 2020-11-27 14:22:44 UTC
Let's mark this as resolved now. Also, retitling this bug so be less grandiose, what I ended up fixing here is just the display of these complicated emojis.
Comment 10 Commit Notification 2020-12-05 18:49:40 UTC
Tor Lillqvist committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/c808dc652ff5c899c4b7f1b676b5a0a0074db1da

tdf#138481: Trust the built-in break iterator character data in ICU

It will be available in 7.0.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.