Download it now!
Bug 138483 - EDITING Validation circles not updated when circled cells get merged
Summary: EDITING Validation circles not updated when circled cells get merged
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.2.0.0.alpha0+ Master
Hardware: All All
: medium normal
Assignee: Tibor Nagy (NISZ)
URL:
Whiteboard: target:7.2.0 target:7.1.0.0.beta2
Keywords:
Depends on:
Blocks: Cell-Validity
  Show dependency treegraph
 
Reported: 2020-11-25 12:28 UTC by NISZ LibreOffice Team
Modified: 2020-12-30 14:26 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file from Calc with validation errors (11.67 KB, application/vnd.oasis.opendocument.spreadsheet)
2020-11-25 12:28 UTC, NISZ LibreOffice Team
Details
Screenshot of the example file in Calc before merging cells with validation errors (24.86 KB, image/png)
2020-11-25 12:28 UTC, NISZ LibreOffice Team
Details
Screenshot of the example file in Calc after merging cells with validation errors (25.23 KB, image/png)
2020-11-25 12:29 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2020-11-25 12:28:36 UTC
Created attachment 167558 [details]
Example file from Calc with validation errors

If there are validation circles on Calc cells and those cells are merged, the validation circles stay behind instead of the newly merged cells validity being evaluated.
Attached file has some cells with validity of Whole number > 5. 

Steps to reproduce:
    1. Open attached file
    2. Merge cells A1 and B1
    3. Merge cells A3 and B3
    4. Merge cells A6:C6
    5. Merge cells A10 and B10
    6. Unmerge cells A12:B12

Actual results:
Validation circle is not expanded in A1:B1.
Two validation circles remain in A3:B3 and A6:C6.
The validation circle does not disappear from B10, since after merging the value of 6 in A10 satisfies the validity criteria.
Validation circle is not shrunk to A12 from the formerly merged A12:B12 cell.

Expected results:
Expanded validation circle around A1:B1.
One validation circle around A3:B3 and A6:C6 
No circle around A10:B10 since the criteria is now met.
Validation circle around A12 only and nothing aroung B12.

LibreOffice details:
Version: 7.2.0.0.alpha0+ (x64)
Build ID: cb084f475db33a2cfc62bc9c8de37b8c3c87b3c7
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: en-US
Calc: CL
Comment 1 NISZ LibreOffice Team 2020-11-25 12:28:58 UTC
Created attachment 167559 [details]
Screenshot of the example file in Calc before merging cells with validation errors
Comment 2 NISZ LibreOffice Team 2020-11-25 12:29:13 UTC
Created attachment 167560 [details]
Screenshot of the example file in Calc after merging cells with validation errors
Comment 3 Commit Notification 2020-11-30 13:24:32 UTC
Tibor Nagy committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/3741b90abe478fb04db88207b496a5238df35bb8

tdf#138483 sc: update red circles after merging cells

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2020-11-30 17:10:15 UTC
László Németh committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/210ec3ef966b2f9206e9e52781f4cb9d2ed46300

Revert "tdf#138483 sc: update red circles after merging cells"

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2020-11-30 19:45:30 UTC
Tibor Nagy committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/df36ac613e43934e49edd3f087d78c7c54ac92ee

tdf#138483 sc: update red circles after merging cells

It will be available in 7.1.0.0.beta2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2020-12-01 09:13:37 UTC
László Németh committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/b18c7096af799e49bc27771cd1500c4eff6bb780

Revert "Revert "tdf#138483 sc: update red circles after merging cells""

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 NISZ LibreOffice Team 2020-12-30 14:26:07 UTC
Verified in:

Version: 7.2.0.0.alpha0+ (x64)
Build ID: 368c56144aab5794c39d5bc2082d9b3d6d7cebdb
CPU threads: 4; OS: Windows 10.0 Build 17134; UI render: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: hu-HU
Calc: threaded

Thanks for fixing!