Bug 138532 - delete checkmark from "Search Criteria = and <> must apply to whole cells" without effect
Summary: delete checkmark from "Search Criteria = and <> must apply to whole cells" wi...
Status: RESOLVED DUPLICATE of bug 139612
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.1.0.0.beta1+
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-11-27 19:00 UTC by Rainer Bielefeld Retired
Modified: 2022-06-25 08:03 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Test Document (82.48 KB, application/vnd.oasis.opendocument.spreadsheet)
2020-11-28 18:02 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2020-11-27 19:00:04 UTC
My result with Version: 
7.1.0.0.beta1 (x64)  Build ID: 828a45a14a0b954e0e539f5a9a10ca31c81d8f53
CPU threads: 4; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-US
Calc: CL

I used a Spreadsheet with formula like 
"=SUM(N417:N537)-(SUMIF(O417:O537;"=R";M417:M537)*1)" to check cells with contents "R2011024"
I need "contains 'R'", not "='R'
So I dropped check ark from Calc Calcule preference. 
Expected: "R" in "R2011024" will be respected and make a difference to empty cells
Actual: no difference between Checked and unchecked.

For My test document I tried OOo 4.2, result after having unchecked as expected, the "R" makes a difference to empty cells.

I saved the document and reopened it in LibO 7: correct result in calculation respecting "R"
I checked Preference: as expected no longer any difference between cells "R2011024" and empty cellx.
I unchecked Preference: no change in calculation result.

So changing from "unchecked" to "checked" will be respected in results
But:
Changing from "checked" to "unchecked" will NOT be respected in results 😥

I will attach test document, soon
Comment 1 Rainer Bielefeld Retired 2020-11-28 18:02:59 UTC
Created attachment 167641 [details]
Test Document

Add / remove checkmark in Preference "Sesarch criteria ..." should toggle caclulation in Cell B7 between 1 and 101 

☺ Works as expected for me until 6.0.0.0.alpha1+
😥 Alwys works as if checked with result "1" in B7 Starting with 6.1.0.0.alpha1
Comment 2 m.a.riosv 2020-11-29 22:25:01 UTC
Reproducible
Version: 6.4.7.2 (x64)
Build ID: 639b8ac485750d5696d7590a72ef1b496725cfb5
CPU threads: 4; OS: Windows 10.0 Build 20180; UI render: GL; VCL: win; 
Locale: es-ES (es_ES); UI-Language: en-US Calc: CL

It happens with/without the = before the R
Comment 3 Luboš Luňák 2022-06-25 08:03:44 UTC

*** This bug has been marked as a duplicate of bug 139612 ***