Bug 138650 - Columns in multicolumns header lost when DOC/DOCX file is saved
Summary: Columns in multicolumns header lost when DOC/DOCX file is saved
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.3.1 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: DOCX-Header-Footer DOCX-Section
  Show dependency treegraph
 
Reported: 2020-12-03 20:44 UTC by Angel
Modified: 2021-06-11 08:52 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file of the bug (64.79 KB, application/zip)
2020-12-03 20:45 UTC, Angel
Details
The original document and its docx version in LO 7.2alpha (116.55 KB, image/png)
2020-12-04 08:33 UTC, NISZ LibreOffice Team
Details
Screenshot of the header editing capabilities of Word 2013 and Writer (135.01 KB, image/png)
2020-12-04 08:43 UTC, NISZ LibreOffice Team
Details
The example file turned into a two column header odt (72.09 KB, application/vnd.oasis.opendocument.text)
2020-12-04 08:45 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Angel 2020-12-03 20:44:21 UTC
Description:
If you have a file heather with more than one column and save the file, when you reopen it the heather has lost the multiple column configuration, but it seems the content is not lost.
This happen when you save it in DOC or DOCX formal. It seems it doesn´t happen in the ODT format

Steps to Reproduce:
1.Open the example file attached
2.There are two logos in the heather of the file. Select both logos
3.Go to format and choose two columns for the heather
4.The heather now should show both logos sode by side in the heather
5.Save the file
6. Close it
7. Reopen it

You will find the logos in the original position, one over the other and the heather with only one column

Actual Results:
The two columns configuration is lost after save the file in DOC7DOCX format. I tested in ODT and it seems there are no problems there

Expected Results:
It should not happen


Reproducible: Always


User Profile Reset: No



Additional Info:
.
Comment 1 Angel 2020-12-03 20:45:01 UTC
Created attachment 167810 [details]
Example file of the bug
Comment 2 NISZ LibreOffice Team 2020-12-04 08:33:54 UTC Comment hidden (obsolete)
Comment 3 NISZ LibreOffice Team 2020-12-04 08:39:13 UTC Comment hidden (no-value)
Comment 4 NISZ LibreOffice Team 2020-12-04 08:43:07 UTC
Created attachment 167814 [details]
Screenshot of the header editing capabilities of Word 2013 and Writer

It seems like Word does not allow setting multiple column layout in the header. The dropdown for this is greyed out on my Word 2013 once I open the header.
Comment 5 NISZ LibreOffice Team 2020-12-04 08:45:01 UTC
Created attachment 167815 [details]
The example file turned into a two column header odt

Made with:

Version: 7.2.0.0.alpha0+ (x64)
Build ID: 561e5559bb68242c7f785f0ca3bee3eb12b58963
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win
Locale: en-US (hu_HU); UI: en-US
Calc: CL
Comment 6 NISZ LibreOffice Team 2020-12-04 08:48:14 UTC
@Justin: maybe you have some insight into this. 
Would it be possible to do some magic tricks with sections or something, to support this layout?
Comment 7 Justin L 2020-12-04 13:03:10 UTC
(In reply to NISZ LibreOffice Team from comment #4)
 It seems like Word does not allow setting multiple column layout in the
> header.
This is also true for Word 2016. Since this is not possible in MS Word, this is NOTABUG. It is a limitation of Microsoft's document format.

I don't see any need to try to "emulate" columns in this situation. What might work nice for one document probably won't work for another document. (Sections also are not allowed in headers.)
Comment 8 NISZ LibreOffice Team 2021-06-11 08:52:06 UTC
Closing per last comment.

From user perspective it's better to use a 2x1 table with images anchored "As Character" and the paragraphs inside the table centered. 
That gives the same look even after saving to docx and opening in Word.