Bug 138848 - Copy-and-Paste in input box should not append an ENTER character (gtk3)
Summary: Copy-and-Paste in input box should not append an ENTER character (gtk3)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All Linux (All)
: low trivial
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.2.0 target:7.1.1
Keywords: bibisected, bisected, regression
: 139738 (view as bug list)
Depends on:
Blocks: GTK3
  Show dependency treegraph
 
Reported: 2020-12-12 11:46 UTC by Kevin Suo
Modified: 2021-01-18 10:28 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
see the ENTER (return) char in the bottom-left find box (95.16 KB, image/png)
2020-12-12 17:21 UTC, Kevin Suo
Details
screenshot (220.25 KB, image/png)
2021-01-09 03:54 UTC, Berna
Details
Screencast from 7.0.4.2 (155.17 KB, image/gif)
2021-01-18 10:28 UTC, Dan Dascalescu
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Suo 2020-12-12 11:46:17 UTC
Steps to Reproduce:
1. Input some content in a cell (e.g., "abc");
2. Select the cell and ctrl+C;
3. Paste in input boxes such as the ctrl+F find box, using ctrl+V.

Current Result:
"abc<ENTER>"

Expected Result:
"abc" without ENTER character.

The appended ENTER char is useless and each time I paste in the search box I need to manually delete it which is really a waste of time.
Comment 1 m.a.riosv 2020-12-12 16:37:01 UTC
I can't repro
Version: 7.2.0.0.alpha0+ (x64)
Build ID: 35e471bb4d1388cf5afcdcee214cf5111edf44e3
CPU threads: 4; OS: Windows 10.0 Build 20180; UI render: Skia/Raster; VCL: win
Locale: es-ES (es_ES); UI: en-US Calc: CL

Can you attach a sample file with the cell to copy.
Comment 2 Kevin Suo 2020-12-12 17:21:00 UTC
Created attachment 168109 [details]
see the ENTER (return) char in the bottom-left find box

(In reply to m.a.riosv from comment #1)

Any Calc document. I mean single-click on the cell (not double-click and select text within the cell), ctrl+C and then Ctrl+V to paste to the find box.
Comment 3 Berna 2021-01-09 03:54:40 UTC
Created attachment 168780 [details]
screenshot
Comment 4 Berna 2021-01-09 03:57:03 UTC
I cannot reproduce.

Version: 7.0.4.2
Build ID: dcf040e67528d9187c66b2379df5ea4407429775
CPU threads: 8; OS: Mac OS X 10.13.6; UI render: default; VCL: osx
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 5 Buovjaga 2021-01-09 07:59:49 UTC
Only seen with gtk3.

Bibisected with linux-64-7.0 to https://git.libreoffice.org/core/commit/3b8c42a94b5448364d47daa103b3452f54990524
weld FindTextFieldControl

Adding Cc: to Caolán McNamara
Comment 6 Caolán McNamara 2021-01-14 11:50:16 UTC
adding "truncate-multiline" true to GtkSpinButton/GtkEntry/GtkComboBoxText might be the way to go to get that working in gtk the same as it does in gen
Comment 7 Commit Notification 2021-01-15 09:11:27 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/f89b94c280e8d986cdf08271f5cdc6b1dfe09575

tdf#138848 add truncate-multiline to all GtkEntries and GtkSpinButtons

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Caolán McNamara 2021-01-15 09:22:58 UTC
done in master, a backport to 7-1 is in gerrit
Comment 9 Commit Notification 2021-01-15 09:52:10 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/2e60514e16c4ca1350fce33794e93ce417b52c40

tdf#138848 add truncate-multiline to all GtkEntries and GtkSpinButtons

It will be available in 7.1.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Dan Dascalescu 2021-01-18 10:28:39 UTC
Created attachment 168986 [details]
Screencast from 7.0.4.2

Can still repro in 7.0.4.2.
Comment 11 Dan Dascalescu 2021-01-18 10:28:55 UTC
*** Bug 139738 has been marked as a duplicate of this bug. ***