Bug 138873 - Selection sticks and doesn't disappear
Summary: Selection sticks and doesn't disappear
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3 all versions
Hardware: All All
: low trivial
Assignee: Not Assigned
URL:
Whiteboard: target:7.3.0 target:7.2.3 target:7.1.7
Keywords: bibisected, bisected, regression
: 138745 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-12-13 08:52 UTC by Telesto
Modified: 2021-10-14 19:41 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file (8.24 KB, application/vnd.oasis.opendocument.text)
2020-12-13 08:52 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-12-13 08:52:14 UTC
Description:
Selecting sticks and doesn't disappear

Steps to Reproduce:
1. Open the attached file
2. Place cursor after World
3. CTRL+SHIFT LEFT
4. Type AAA
5. Press CTRL+Z 2x
6. Press SHIFT ARROW LEFT (without removing prior selection)

Actual Results:
Selection stuck

Expected Results:
Should disappear


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.2.0.0.alpha0+ (x64)
Build ID: 35e471bb4d1388cf5afcdcee214cf5111edf44e3
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 1 Telesto 2020-12-13 08:52:25 UTC
Created attachment 168126 [details]
Example file
Comment 2 Telesto 2020-12-13 08:53:15 UTC
Still OK In
Version: 6.2.9.0.0+ (x86)
Build ID: 5f01fe15eb2661f1f9ce12d1d99dc2a705b462ee
CPU threads: 4; OS: Windows 6.3; UI render: GL; VCL: win; 
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: CL
Comment 3 Aron Budea 2020-12-20 05:54:47 UTC
No repro.
After step 5, "World" should be selected, right?

Version: 7.2.0.0.alpha0+ (x64)
Build ID: e97a81e94511b52987a50b7bdb72c922899da588
CPU threads: 4; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: Skia/Raster; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: CL
Comment 4 Xisco Faulí 2021-02-23 09:05:25 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/sw/?id=6abed0ea006f3616e40faf2ae782cf64f8ac2914

author	Phil Krylov <phil.krylov@gmail.com>	2019-02-10 04:31:15 +0300
committer	Mike Kaganski <mike.kaganski@collabora.com>	2019-03-13 11:27:52 +0100
commit 6abed0ea006f3616e40faf2ae782cf64f8ac2914 (patch)
tree edb02b8c979b886b65816aa0b56f60ddbd7708be /sw
parent 3df0d6e3e161a63282e58f31b197c2d1ba28a6b5 (diff)
tdf#79717 save/restore character format on selection overwrite

Bisected with: bibisect-linux64-6.3

Adding Cc: to Phil Krylov
Comment 5 Telesto 2021-02-23 14:33:52 UTC
*** Bug 138745 has been marked as a duplicate of this bug. ***
Comment 6 Justin L 2021-03-26 12:37:02 UTC
It isn't quite correct to say that the selection has stuck. It LOOKS like "World" is selected, but if you press delete (as step 6), then "World" is not deleted, so it wasn't actually selected. It is just a piece of layout that never disappears. You can do all kinds of editing or selecting, and it just stays there.
Comment 7 Telesto 2021-03-27 13:58:09 UTC
@Justin

(In reply to Justin L from comment #6)
> It isn't quite correct to say that the selection has stuck. It LOOKS like
> "World" is selected, but if you press delete (as step 6), then "World" is
> not deleted, so it wasn't actually selected. It is just a piece of layout
> that never disappears. You can do all kinds of editing or selecting, and it
> just stays there.

This correct, however sometimes struggling with the proper phrasing. Any suggestion how the title could be optimized to reflect the actual issue?

Because something like : It LOOKS like World" is selected, but this isn't the case isn't self-explaining either :-(
Comment 8 Commit Notification 2021-10-14 06:46:19 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/036d45b602c2f554f9bcc21fecbc3e3ac5b834da

tdf#134426 tdf#138873 sw:  Revert "tdf#79717 ...

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Justin L 2021-10-14 07:10:28 UTC
I was no longer able to replicate this bug at all - trying bibisect 6.3, 7.0, 7.1, 7.3. But in any case, the bisected commit is being reverted anyway, so this bug is fixed.
Comment 10 Commit Notification 2021-10-14 08:18:44 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "libreoffice-7-2":

https://git.libreoffice.org/core/commit/49e8691530ea931eeee74fd88727c2451e98a3bd

tdf#134426 tdf#138873 sw:  Revert "tdf#79717 ...

It will be available in 7.2.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2021-10-14 10:24:23 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/08ede5d51a33f83ededee8a03c10f9bb8244690e

tdf#134426 tdf#138873 sw:  Revert "tdf#79717 ...

It will be available in 7.1.7.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Telesto 2021-10-14 10:57:40 UTC
(In reply to Justin L from comment #9)
> I was no longer able to replicate this bug at all - trying bibisect 6.3,
> 7.0, 7.1, 7.3. But in any case, the bisected commit is being reverted
> anyway, so this bug is fixed.

I still present in current builds *before* the revert
Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 93115d2c54d645bcf2f80fde325e3ede39dee4d5
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL

will verify tomorrow
Comment 13 Commit Notification 2021-10-14 19:41:59 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/12bd8d8d50da871e8f6be57ce46083f84d493d8b

tdf#138873: sw_uiwriter: Add unittest

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.