Bug 138923 - [FILEOPEN] Improper Calibri font substitution breaks display layout of presentation
Summary: [FILEOPEN] Improper Calibri font substitution breaks display layout of presen...
Status: RESOLVED DUPLICATE of bug 61134
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
7.0.3.1 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-12-15 01:38 UTC by Julien Adetele
Modified: 2021-09-04 06:04 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
How LIbreOffice displays the presentation (32.79 KB, image/png)
2020-12-15 01:39 UTC, Julien Adetele
Details
How Microsoft PowerPoint displays the presentation (21.06 KB, image/png)
2020-12-15 01:39 UTC, Julien Adetele
Details
The offending presentation (81.80 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2020-12-15 01:40 UTC, Julien Adetele
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Julien Adetele 2020-12-15 01:38:52 UTC
Description:
I am going to attach a presentation which was part of a larger internal presentation that I have masked for the purpose of bug reporting.

If you open this presentation in LibreOffice Impress, the text is messed up and goes outside page borders. Microsoft PowerPoint displays it ok.

Version: 7.0.3.1
Build ID: 00(Build:1)
CPU threads: 12; OS: Linux 5.8; UI render: default; VCL: kf5
Locale: en-US (en_US.UTF-8); UI: en-US
Ubuntu package version: 1:7.0.3-0ubuntu0.20.10.1
Calc: threaded

Steps to Reproduce:
Open the presentation

Actual Results:
Text outside page borders

Expected Results:
Should be displayed as Microsoft PowerPoint displays it


Reproducible: Always


User Profile Reset: No



Additional Info:
No other information
Comment 1 Julien Adetele 2020-12-15 01:39:09 UTC
Created attachment 168174 [details]
How LIbreOffice displays the presentation
Comment 2 Julien Adetele 2020-12-15 01:39:34 UTC
Created attachment 168175 [details]
How Microsoft PowerPoint displays the presentation
Comment 3 Julien Adetele 2020-12-15 01:40:15 UTC
Created attachment 168176 [details]
The offending presentation
Comment 4 Julien Adetele 2020-12-15 12:15:49 UTC
Seems fixed in this version:

Version: 7.1.0.0.beta1
Build ID: 828a45a14a0b954e0e539f5a9a10ca31c81d8f53
CPU threads: 12; OS: Linux 5.8; UI render: default; VCL: kf5
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: CL
Comment 5 Marina Latini (SUSE) 2020-12-16 21:22:36 UTC
No repro:

Versione: 6.4.5.2
Build ID: 40(Build:2)
Thread CPU: 2; SO: Linux 5.3; Resa interfaccia: predefinito; VCL: gtk3; 
Versione locale: it-IT (en_US.UTF-8); Lingua interfaccia: it-IT
Calc: threaded

OS: "SUSE Linux Enterprise Desktop 15 SP2"


No repro:

Version: 7.0.3.1
Build ID: d7547858d014d4cf69878db179d326fc3483e082
CPU threads: 2; OS: Linux 5.3; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 6 Marina Latini (SUSE) 2020-12-16 21:28:50 UTC
No repro:

Version: 7.0.3.1
Build ID: 00(Build:1)
CPU threads: 8; OS: Linux 5.3; UI render: default; VCL: kf5
Locale: it-IT (it_IT.UTF-8); Interfaccia utente: it-IT
Calc: threaded

OS: openSUSE Leap 15.2
KDE Plasma: 5.20.4
KDE Frameworks: 5.77.0
Qt: 5.15.2
Comment 7 Julien Adetele 2020-12-17 02:02:04 UTC
Hello,

this problem happens on a fresh installation of Kubuntu 20.10. The LibreOffice version installed is 7.0.2.2.

However, after running `sudo apt-get upgrade libreoffice`, the problem disappears. But, after the upgrade, the LibreOffice version is still 7.0.2.2.

I noticed that the `upgrade` command installs a lot of fonts packags, packages named "fonts-*".

May it be a problem of missing fonts?

The font used in the presentation is Calibre Light for the title and Calibre for the text. But I have noticed that both BEFORE and AFTER the upgrade, LibreOffice tells me that the font is missing and will be substituted.

Is it possible that BEFORE the upgrade it substitutes it with font X, not fully working apparently, and AFTER the upgrade, it substitutes it with the new font Y, which apparently is better working?

How do I find out the substitute font that LibreOffice is using?
Comment 8 Julien Adetele 2020-12-17 03:28:39 UTC
This is definitively a font issue.

The problem happens on a fresh installation of Kubuntu 20.10.

There "Calibri" is substituted with "Noto Sans", according to "fc-match"

Installing the package "fonts-crosextra-carlito" fixes the issue.

I think LibreOffice should:

1. Issue a warning, either (i) the font is not present and will be substituted or (ii) the font is not present, will be substituted but the substitution is dangerous (such as in this case, perhaps maintaining a list of "dangerous" substitutions)

2. It would be great if LibreOffice offer the user to download automatically a better font for the substitution (perhaps maintaining its own repository of open-source font). This is what Wine does, which offer the user to download a Gecko version and a Mono version

Either way I think a solution should be provided. It took me days to track this down to font issue, I don't think an average user should be required to do that (and he/she will probably not but just uninstall LibreOffice thinking it is bugged)
Comment 9 Aron Budea 2021-02-14 07:14:40 UTC
There are various bug reports on better informing the user on form substitution already: bug 61134, bug 96872.
Comment 10 Julien Adetele 2021-09-04 06:04:56 UTC
marking as duplicate of the other

*** This bug has been marked as a duplicate of bug 61134 ***