Bug 139075 - UI: Format Cell, borders Borders tab has drawing glitches when applying diagonal lines
Summary: UI: Format Cell, borders Borders tab has drawing glitches when applying diago...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.2.0 target:7.1.3 target:7.0.6
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2020-12-19 19:52 UTC by Telesto
Modified: 2021-04-12 09:01 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot (83.25 KB, image/jpeg)
2020-12-19 19:52 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-12-19 19:52:08 UTC
Description:
UI: Format Cell, borders Borders tab has drawing glitches when applying diagonal lines

Steps to Reproduce:
1. Open Calc
2. Right click a cell -> Format cell -> Border tab
3. Click in the border tool (enabling diagonal line left top, right bottom

Actual Results:
See screenshot

Expected Results:
Nice and clean (no spurious stuff)


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.2.0.0.alpha0+ (x64)
Build ID: 315c7570c4a72f4c834086082825533b1e50d1bf
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 1 Telesto 2020-12-19 19:52:22 UTC
Created attachment 168345 [details]
Screenshot
Comment 2 Telesto 2020-12-19 19:54:31 UTC
Also in 
Version: 7.0.0.0.alpha0+ (x64)
Build ID: 11785217594d863efb518aa8b8f2910cdcb9c59d
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win; 
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: CL
Comment 3 Telesto 2020-12-19 19:56:43 UTC
Also in
6.4

Maybe something present in (however less prominent)
Version: 6.2.9.0.0+ (x86)
Build ID: 5f01fe15eb2661f1f9ce12d1d99dc2a705b462ee
CPU threads: 4; OS: Windows 6.3; UI render: GL; VCL: win; 
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: CL
Comment 4 raal 2021-04-07 17:39:52 UTC
I can confirm with Version: 7.2.0.0.alpha0+ / LibreOffice Community
Build ID: c47ad11f8c2e917adebbd5d7b3a3ef6cc4b3e670
CPU threads: 4; OS: Linux 5.8; UI render: default; VCL: x11
Locale: cs-CZ (cs_CZ.UTF-8); UI: en-US
Calc: threaded
Comment 5 raal 2021-04-07 17:46:49 UTC
This seems to have begun at the below commit.
Adding Cc: to Caolán McNamara ; Could you possibly take a look at this one?
Thanks
bibisect-41max dc72eff215e85619e6506f05307f89c35641606b is the first bad commit
commit dc72eff215e85619e6506f05307f89c35641606b
Author: Matthew Francis <mjay.francis@gmail.com>
Date:   Fri Sep 18 10:20:18 2015 +0800

    source-hash-03f7d96997e8d9cde6b82936792dee4d3a756eda
    
    commit 03f7d96997e8d9cde6b82936792dee4d3a756eda
    Author:     Caolán McNamara <caolanm@redhat.com>
    AuthorDate: Sun Jan 13 23:07:52 2013 +0000
    Commit:     Caolán McNamara <caolanm@redhat.com>
    CommitDate: Tue Jan 15 14:58:05 2013 +0000
    
        split out border page and adapt code
    
        Change-Id: I1c6b8c0fdbd82d54920e168afbe5c33a29244202
Comment 6 Caolán McNamara 2021-04-09 19:52:21 UTC
looks like the error is in:

commit 356f6c5d89dd4dd92b2351898e07f99b96cb34cc
Author: Caolán McNamara <caolanm@redhat.com>

    teach FrameSelector to be resizable

though that probably only becomes possible to see then later in
commit 03f7d96997e8d9cde6b82936792dee4d3a756eda
Author: Caolán McNamara <caolanm@redhat.com>

    split out border page and adapt code
Comment 7 Commit Notification 2021-04-10 11:32:59 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/3cf47860832707baa67833af0ae40e23a925ddc2

Resolves: tdf#139075 diagonal focus rects contain focus rects of old size

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Caolán McNamara 2021-04-10 11:36:36 UTC
fixed in main, backport to 7-1 and 7-0 in gerrit
Comment 9 Commit Notification 2021-04-10 16:02:40 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/b606a278aac6ccc395a26bbb6b7a8a5eae91a809

Resolves: tdf#139075 diagonal focus rects contain focus rects of old size

It will be available in 7.1.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2021-04-12 09:01:29 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/54bb28b8ec9caaf57026e5de0c7c1d66af475415

Resolves: tdf#139075 diagonal focus rects contain focus rects of old size

It will be available in 7.0.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.